Require OpenSSL 1.1.0 or later.
[tinc] / debian / rules
diff --git a/debian/rules b/debian/rules
deleted file mode 100644 (file)
index c07a054..0000000
+++ /dev/null
@@ -1,78 +0,0 @@
-#!/usr/bin/make -f
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-# This is the debhelper compatability version to use.
-export DH_COMPAT=1
-
-build: build-stamp
-build-stamp:
-       dh_testdir
-
-#      # If the Makefile.in.in file in po/ already contains DESTDIR support, skip the patching.
-       cd `pwd`/po ; ( \
-         if ! grep DESTDIR Makefile.in.in > /dev/null ; then \
-           patch -Ns -p0 < `pwd`/../debian/po-Makefile.in.in.diff || true ;\
-         fi ;\
-       )
-
-       env CFLAGS='-O2 -Wall' ./autogen.sh --prefix=/usr --mandir=\$${prefix}/share/man \
-               --infodir=\$${prefix}/share/info --sysconfdir=/etc --localstatedir=/var
-
-       $(MAKE)
-
-       touch build-stamp
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp
-
-       -$(MAKE) cvs-clean
-
-       dh_clean
-
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k
-       dh_installdirs
-
-       $(MAKE) install DESTDIR=`pwd`/debian/tmp
-       mkdir -p `pwd`/debian/tmp/etc/tinc
-       cp -a doc/sample-config.tar.gz `pwd`/debian/tmp/etc/tinc/example
-       cd `pwd`/debian/tmp/etc/tinc/example && tar xzf sample-config.tar.gz && rm sample-config.tar.gz
-       ln -s /usr/share/doc/tinc/README.Debian `pwd`/debian/tmp/etc/tinc/example/README
-
-
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
-       dh_testdir
-       dh_testroot
-       dh_installdocs
-       dh_installexamples
-       dh_installinit
-       dh_installmanpages
-       dh_installmodules
-       dh_installinfo
-       dh_installchangelogs ChangeLog
-       dh_link
-       dh_strip
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_perl
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install