Updating HEAD branch #2; removing debian/ dir.
[tinc] / debian / rules
diff --git a/debian/rules b/debian/rules
deleted file mode 100644 (file)
index 397e998..0000000
+++ /dev/null
@@ -1,78 +0,0 @@
-#!/usr/bin/make -f
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-# This is the debhelper compatability version to use.
-export DH_COMPAT=1
-
-build: build-stamp
-build-stamp:
-       dh_testdir
-
-       ./configure --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info --sysconfdir=/etc
-       $(MAKE)
-
-       touch build-stamp
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp
-
-       -$(MAKE) distclean
-
-       dh_clean
-
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k
-       dh_installdirs
-
-       $(MAKE) install DESTDIR=`pwd`/debian/tmp
-       mkdir -p `pwd`/debian/tmp/etc/tinc/example
-       cp doc/tinc.conf.sample `pwd`/debian/tmp/etc/tinc/example/tinc.conf
-       ln -s /usr/share/doc/tinc/README.Debian `pwd`/debian/tmp/etc/tinc/example/README
-       rm -f `pwd`/debian/tmp/usr/lib/tinc/libblowfish.so
-
-
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
-#      dh_testversion
-       dh_testdir
-       dh_testroot
-#      dh_installdebconf       
-       dh_installdocs
-       dh_installexamples
-#      dh_installmenu
-#      dh_installemacsen
-#      dh_installpam
-       dh_installinit
-#      dh_installcron
-       dh_installmanpages
-       dh_installinfo
-#      dh_undocumented
-       dh_installchangelogs ChangeLog
-       dh_link
-       dh_strip
-       dh_compress
-       dh_fixperms
-#      # You may want to make some executables suid here.
-#      dh_suidregister
-#      dh_makeshlibs
-       dh_installdeb
-#      dh_perl
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install