Fix rules (thanks to Laurence)
[tinc] / debian / rules
index f52e891..397e998 100644 (file)
@@ -32,9 +32,10 @@ install: build
        dh_clean -k
        dh_installdirs
 
-       $(MAKE) install prefix=`pwd`/debian/tmp/usr
-       mkdir -p `pwd`/debian/tmp/etc/tinc
-       cp doc/tinc.conf.sample `pwd`/debian/tmp/etc/tinc/tinc.conf
+       $(MAKE) install DESTDIR=`pwd`/debian/tmp
+       mkdir -p `pwd`/debian/tmp/etc/tinc/example
+       cp doc/tinc.conf.sample `pwd`/debian/tmp/etc/tinc/example/tinc.conf
+       ln -s /usr/share/doc/tinc/README.Debian `pwd`/debian/tmp/etc/tinc/example/README
        rm -f `pwd`/debian/tmp/usr/lib/tinc/libblowfish.so