Enable silent builds by default.
[tinc] / doc / Makefile.am
index 9f3f7eb..4af40a0 100644 (file)
@@ -1,20 +1,12 @@
 ## Process this file with automake to get Makefile.in
 
-SUBDIRS = es
-
 info_TEXINFOS = tinc.texi
 
-dyn_MANS =
-man_aux = $(dyn_MANS:.8=.x)
-
-man_MANS = tincd.8 tinc.conf.5 genauth.8 $(dyn_MANS)
+man_MANS = tincd.8 tinc.8 tinc.conf.5 tinc-gui.8
 
-PERL = @PERL@
-HELP2MAN = help2man
-MAINTAINERCLEANFILES = $(dyn_MANS)
+EXTRA_DIST = tincinclude.texi.in tincd.8.in tinc.8.in tinc.conf.5.in tinc-gui.8.in sample-config.tar.gz
 
-EXTRA_DIST = $(man_MANS) $(HELP2MAN) $(man_aux) \
-  Makefile.maint GNUmakefile Makefile.summ tinc.conf.sample
+CLEANFILES = *.html tincd.8 tinc.8 tinc.conf.5 tinc-gui.8 tincinclude.texi
 
 # Use `ginstall' in the definition of man_MANS to avoid
 # confusion with the `install' target.  The install rule transforms `ginstall'
@@ -23,3 +15,41 @@ transform = s/ginstall/install/; @program_transform_name@
 
 # For additional rules usually of interest only to the maintainer,
 # see GNUmakefile and Makefile.maint.
+
+sample-config.tar.gz: sample-config
+       $(AM_V_GEN)GZIP=$(GZIP_ENV) $(AMTAR) chozf $@ --exclude .svn $<
+
+tincd.8.html: tincd.8
+       $(AM_V_GEN)w3mman2html $? > $@
+
+tinc.8.html: tinc.8
+       $(AM_V_GEN)w3mman2html $? > $@
+
+tinc-gui.8.html: tinc-gui.8
+       $(AM_V_GEN)w3mman2html $? > $@
+
+tinc.conf.5.html: tinc.conf.5
+       $(AM_V_GEN)w3mman2html $? > $@
+
+substitute = sed \
+       -e s,'@PACKAGE\@',"$(PACKAGE)",g \
+       -e s,'@VERSION\@',"$(VERSION)",g \
+       -e s,'@sysconfdir\@',"$(sysconfdir)",g \
+       -e s,'@localstatedir\@',"$(localstatedir)",g
+
+tincd.8: tincd.8.in
+       $(AM_V_GEN)$(substitute) $? > $@
+
+tinc.8: tinc.8.in
+       $(AM_V_GEN)$(substitute) $? > $@
+
+tinc-gui.8: tinc-gui.8.in
+       $(AM_V_GEN)$(substitute) $? > $@
+
+tinc.conf.5: tinc.conf.5.in
+       $(AM_V_GEN)$(substitute) $? > $@
+
+tincinclude.texi: tincinclude.texi.in
+       $(AM_V_GEN)$(substitute) $? > $@
+       
+tinc.texi: tincinclude.texi