Merge branch 'master' into 1.1
[tinc] / doc / Makefile.am
index 7985251..66de6d9 100644 (file)
@@ -2,11 +2,11 @@
 
 info_TEXINFOS = tinc.texi
 
-man_MANS = tincd.8 tinc.conf.5
+man_MANS = tincd.8 tincctl.8 tinc.conf.5
 
-EXTRA_DIST = tincinclude.texi.in tincd.8.in tinc.conf.5.in sample-config.tar.gz
+EXTRA_DIST = tincinclude.texi.in tincd.8.in tincctl.8.in tinc.conf.5.in sample-config.tar.gz
 
-CLEANFILES = *.html tinc.info tincd.8 tinc.conf.5 tincinclude.texi
+CLEANFILES = *.html tinc.info tincd.8 tincctl.8 tinc.conf.5 tincinclude.texi
 
 # Use `ginstall' in the definition of man_MANS to avoid
 # confusion with the `install' target.  The install rule transforms `ginstall'
@@ -22,7 +22,13 @@ sample-config.tar.gz: sample-config
 texi2html: tinc.texi
        texi2html -split=chapter tinc.texi
 
-%.html: $(man_MANS)
+tincd.8.html: tincd.8
+       w3mman2html $< > $@
+
+tincctl.8.html: tincctl.8
+       w3mman2html $< > $@
+
+tinc.conf.5.html: tinc.conf.5
        w3mman2html $< > $@
 
 substitute = sed \
@@ -34,6 +40,9 @@ substitute = sed \
 tincd.8: tincd.8.in
        $(substitute) tincd.8.in > tincd.8
 
+tincctl.8: tincctl.8.in
+       $(substitute) tincctl.8.in > tincctl.8
+
 tinc.conf.5: tinc.conf.5.in
        $(substitute) tinc.conf.5.in > tinc.conf.5