Update documentation and remove stuff that's too outdated.
[tinc] / doc / Makefile.am
index d0bdb3a..6714dba 100644 (file)
@@ -1,18 +1,20 @@
 ## Process this file with automake to get Makefile.in
 
+SUBDIRS = es
+
 info_TEXINFOS = tinc.texi
 
 dyn_MANS =
 man_aux = $(dyn_MANS:.8=.x)
 
-man_MANS = tincd.8 tinc.conf.5 genauth.8 $(dyn_MANS)
+man_MANS = tincd.8 tinc.conf.5 $(dyn_MANS)
 
 PERL = @PERL@
 HELP2MAN = help2man
 MAINTAINERCLEANFILES = $(dyn_MANS)
 
 EXTRA_DIST = $(man_MANS) $(HELP2MAN) $(man_aux) \
-  Makefile.maint GNUmakefile Makefile.summ tinc.conf.sample
+  Makefile.maint GNUmakefile Makefile.summ sample-config.tar.gz
 
 # Use `ginstall' in the definition of man_MANS to avoid
 # confusion with the `install' target.  The install rule transforms `ginstall'
@@ -21,3 +23,14 @@ transform = s/ginstall/install/; @program_transform_name@
 
 # For additional rules usually of interest only to the maintainer,
 # see GNUmakefile and Makefile.maint.
+
+tinc.pdf: tinc.texi
+       texi2pdf -o tinc.pdf tinc.texi
+
+texi2html: tinc.texi
+       mkdir -p html
+       rm -f html/*.html
+       cd html && texi2html -split=chapter ../tinc.texi
+
+%.html: %
+       w3mman2html $< > $@