Fix building documentation when using OpenBSD's make.
[tinc] / doc / Makefile.am
index 9540b49..b2bcb4e 100644 (file)
@@ -4,55 +4,42 @@ info_TEXINFOS = tinc.texi
 
 man_MANS = tincd.8 tinc.8 tinc.conf.5 tinc-gui.8
 
-EXTRA_DIST = tincinclude.texi.in tincd.8.in tinc.8.in tinc.conf.5.in tinc-gui.8.in sample-config.tar.gz
+EXTRA_DIST = tincinclude.texi.in tincd.8.in tinc.8.in tinc.conf.5.in tinc-gui.8.in sample-config
 
-CLEANFILES = *.html tinc.info tincd.8 tinc.8 tinc.conf.5 tinc-gui.8 tincinclude.texi
-
-# Use `ginstall' in the definition of man_MANS to avoid
-# confusion with the `install' target.  The install rule transforms `ginstall'
-# to install before applying any user-specified name transformations.
-transform = s/ginstall/install/; @program_transform_name@
-
-# For additional rules usually of interest only to the maintainer,
-# see GNUmakefile and Makefile.maint.
-
-sample-config.tar.gz: sample-config
-       GZIP=$(GZIP_ENV) $(AMTAR) chozf sample-config.tar.gz --exclude .svn sample-config
-
-texi2html: tinc.texi
-       texi2html -split=chapter tinc.texi
+CLEANFILES = *.html tincd.8 tinc.8 tinc.conf.5 tinc-gui.8 tincinclude.texi tinc.info
 
 tincd.8.html: tincd.8
-       w3mman2html $? > $@
+       $(AM_V_GEN)w3mman2html $? > $@
 
 tinc.8.html: tinc.8
-       w3mman2html $? > $@
+       $(AM_V_GEN)w3mman2html $? > $@
 
 tinc-gui.8.html: tinc-gui.8
-       w3mman2html $? > $@
+       $(AM_V_GEN)w3mman2html $? > $@
 
 tinc.conf.5.html: tinc.conf.5
-       w3mman2html $? > $@
+       $(AM_V_GEN)w3mman2html $? > $@
 
 substitute = sed \
        -e s,'@PACKAGE\@',"$(PACKAGE)",g \
        -e s,'@VERSION\@',"$(VERSION)",g \
        -e s,'@sysconfdir\@',"$(sysconfdir)",g \
+       -e s,'@runstatedir\@',"$(runstatedir)",g \
        -e s,'@localstatedir\@',"$(localstatedir)",g
 
-tincd.8: tincd.8.in
-       $(substitute) $? > $@
+tincd.8: $(srcdir)/tincd.8.in
+       $(AM_V_GEN)$(substitute) $(srcdir)/tincd.8.in > $@
 
-tinc.8: tinc.8.in
-       $(substitute) $? > $@
+tinc.8: $(srcdir)/tinc.8.in
+       $(AM_V_GEN)$(substitute) $(srcdir)/tinc.8.in > $@
 
-tinc-gui.8: tinc-gui.8.in
-       $(substitute) $? > $@
+tinc-gui.8: $(srcdir)/tinc-gui.8.in
+       $(AM_V_GEN)$(substitute) $(srcdir)/tinc-gui.8.in > $@
 
-tinc.conf.5: tinc.conf.5.in
-       $(substitute) $? > $@
+tinc.conf.5: $(srcdir)/tinc.conf.5.in
+       $(AM_V_GEN)$(substitute) $(srcdir)/tinc.conf.5.in > $@
 
-tincinclude.texi: tincinclude.texi.in
-       $(substitute) $? > $@
+tincinclude.texi: $(srcdir)/tincinclude.texi.in
+       $(AM_V_GEN)$(substitute) $(srcdir)/tincinclude.texi.in > $@
        
 tinc.texi: tincinclude.texi