Make sure the stop command works on Windows if tincd is running in the foreground.
[tinc] / doc / Makefile.am
index b3af522..e5f3a04 100644 (file)
@@ -1,6 +1,7 @@
 ## Process this file with automake to get Makefile.in
 
 info_TEXINFOS = tinc.texi
+tinc_TEXINFOS = tincinclude.texi
 
 man_MANS = tincd.8 tinc.8 tinc.conf.5 tinc-gui.8
 
@@ -24,21 +25,20 @@ substitute = sed \
        -e s,'@PACKAGE\@',"$(PACKAGE)",g \
        -e s,'@VERSION\@',"$(VERSION)",g \
        -e s,'@sysconfdir\@',"$(sysconfdir)",g \
+       -e s,'@runstatedir\@',"$(runstatedir)",g \
        -e s,'@localstatedir\@',"$(localstatedir)",g
 
-tincd.8: tincd.8.in
-       $(AM_V_GEN)$(substitute) $? > $@
+tincd.8: $(srcdir)/tincd.8.in
+       $(AM_V_GEN)$(substitute) $(srcdir)/tincd.8.in > $@
 
-tinc.8: tinc.8.in
-       $(AM_V_GEN)$(substitute) $? > $@
+tinc.8: $(srcdir)/tinc.8.in
+       $(AM_V_GEN)$(substitute) $(srcdir)/tinc.8.in > $@
 
-tinc-gui.8: tinc-gui.8.in
-       $(AM_V_GEN)$(substitute) $? > $@
+tinc-gui.8: $(srcdir)/tinc-gui.8.in
+       $(AM_V_GEN)$(substitute) $(srcdir)/tinc-gui.8.in > $@
 
-tinc.conf.5: tinc.conf.5.in
-       $(AM_V_GEN)$(substitute) $? > $@
+tinc.conf.5: $(srcdir)/tinc.conf.5.in
+       $(AM_V_GEN)$(substitute) $(srcdir)/tinc.conf.5.in > $@
 
-tincinclude.texi: tincinclude.texi.in
-       $(AM_V_GEN)$(substitute) $? > $@
-       
-tinc.texi: tincinclude.texi
+tincinclude.texi: $(srcdir)/tincinclude.texi.in
+       $(AM_V_GEN)$(substitute) $(srcdir)/tincinclude.texi.in > $@