More updates
[tinc] / m4 / Makefile.am
index f60c83c..b0028d7 100644 (file)
@@ -1,18 +1,15 @@
-## Process this file with automake to produce Makefile.in   -*-Makefile-*-
+## Process this file with automake to produce Makefile.in
+# $Id: Makefile.am,v 1.3 2002/04/09 15:48:54 zarq Exp $
 
-##m4-files-begin
-EXTRA_DIST = README Makefile.am.in malloc.m4 perl.m4 realloc.m4
+noinst_LIBRARIES = libvpn.a
 
-##m4-files-end
+INCLUDES = @INCLUDES@ -I. -I$(top_builddir) -I$(top_srcdir)/intl
 
-Makefile.am: Makefile.am.in
-       rm -f $@ $@t
-       sed -n '1,/^##m4-files-begin/p' $< > $@t
-       ( echo EXTRA_DIST = README Makefile.am.in; \
-         find . -type f -name '*.m4' -print |sed 's,^\./,,' |sort ) \
-         |fmt | (tr '\012' @; echo) \
-             |sed 's/@$$/%/;s/@/ \\@/g' |tr @% '\012\012' \
-               >> $@t
-       sed -n '/^##m4-files-end/,$$p' $< >> $@t
-       chmod a-w $@t
-       mv $@t $@
+libvpn_a_SOURCES = xmalloc.c pidfile.c utils.c getopt.c getopt1.c list.c avl_tree.c dropin.c
+
+libvpn_a_LIBADD = @LIBOBJS@ @ALLOCA@
+libvpn_a_DEPENDENCIES = $(libvpn_a_LIBADD)
+
+noinst_HEADERS = xalloc.h pidfile.h utils.h getopt.h list.h avl_tree.h dropin.h
+
+EXTRA_DIST = README