Remove xmalloc.c, backport xalloc.h from tinc 1.1.
[tinc] / src / Makefile.am
index bdd1a3f..11f701c 100644 (file)
@@ -2,37 +2,89 @@
 
 sbin_PROGRAMS = tincd
 
-EXTRA_DIST = linux/device.c bsd/device.c solaris/device.c cygwin/device.c mingw/device.c mingw/common.h raw_socket/device.c uml_socket/device.c
+tincd_SOURCES = \
+       have.h \
+       system.h \
+       avl_tree.c avl_tree.h \
+       conf.c conf.h \
+       connection.c connection.h \
+       device.h \
+       dropin.c dropin.h \
+       dummy_device.c \
+       edge.c edge.h \
+       ethernet.h \
+       event.c event.h \
+       fake-gai-errnos.h \
+       fake-getaddrinfo.c fake-getaddrinfo.h \
+       fake-getnameinfo.c fake-getnameinfo.h \
+       graph.c graph.h \
+       ipv4.h \
+       ipv6.h \
+       list.c list.h \
+       logger.c logger.h \
+       meta.c meta.h \
+       multicast_device.c \
+       net.c net.h \
+       net_packet.c \
+       net_setup.c \
+       net_socket.c \
+       netutl.c netutl.h \
+       node.c node.h \
+       pidfile.c pidfile.h \
+       process.c process.h \
+       protocol.c protocol.h \
+       protocol_auth.c \
+       protocol_edge.c \
+       protocol_misc.c \
+       protocol_key.c \
+       protocol_subnet.c \
+       proxy.c proxy.h \
+       raw_socket_device.c \
+       route.c route.h \
+       subnet.c subnet.h \
+       tincd.c \
+       utils.c utils.h \
+       xalloc.h
 
-tincd_SOURCES = conf.c connection.c edge.c event.c graph.c logger.c meta.c net.c net_packet.c net_setup.c      \
-       net_socket.c netutl.c node.c process.c protocol.c protocol_auth.c protocol_edge.c protocol_misc.c       \
-       protocol_key.c protocol_subnet.c route.c subnet.c tincd.c
+if !GETOPT
+tincd_SOURCES += \
+       getopt.c getopt.h \
+       getopt1.c
+endif
+
+if LINUX
+tincd_SOURCES += linux/device.c
+endif
 
+if BSD
+tincd_SOURCES += bsd/device.c
 if TUNEMU
-tincd_SOURCES += bsd/tunemu.c
+tincd_SOURCES += bsd/tunemu.c bsd/tunemu.h
+endif
 endif
 
-nodist_tincd_SOURCES = device.c
+if SOLARIS
+tincd_SOURCES += solaris/device.c
+endif
 
-DEFAULT_INCLUDES =
+if MINGW
+tincd_SOURCES += mingw/device.c mingw/common.h
+endif
 
-INCLUDES = @INCLUDES@ -I$(top_builddir) -I$(top_srcdir)/lib
+if CYGWIN
+tincd_SOURCES += cygwin/device.c
+endif
 
-noinst_HEADERS = conf.h connection.h device.h edge.h event.h graph.h logger.h meta.h net.h netutl.h node.h process.h   \
-       protocol.h route.h subnet.h bsd/tunemu.h
+if UML
+tincd_SOURCES += uml_device.c
+endif
 
-LIBS = @LIBS@
+if VDE
+tincd_SOURCES += vde_device.c
+endif
 
 if TUNEMU
 LIBS += -lpcap
 endif
 
-tincd_LDADD = \
-       $(top_builddir)/lib/libvpn.a
-
-localedir = $(datadir)/locale
-
-AM_CFLAGS = @CFLAGS@ -DCONFDIR=\"$(sysconfdir)\" -DLOCALEDIR=\"$(localedir)\" -DLOCALSTATEDIR=\"$(localstatedir)\"
-
-dist-hook:
-       rm -f `find . -type l`
+AM_CPPFLAGS = -DCONFDIR=\"$(sysconfdir)\" -DLOCALSTATEDIR=\"$(localstatedir)\" -I $(abs_top_builddir)/