- Updated CVS_CREATED to remove intl/ directory and some other
[tinc] / src / Makefile.am
index 185e5a0..1f6b44b 100644 (file)
@@ -1,12 +1,12 @@
 ## Produce this file with automake to get Makefile.in
-# $Id: Makefile.am,v 1.4.4.10 2000/11/22 16:19:06 zarq Exp $
+# $Id: Makefile.am,v 1.4.4.12 2001/02/11 11:50:09 guus Exp $
 
 sbin_PROGRAMS = tincd
 
 tincd_SOURCES = conf.c connection.c meta.c net.c netutl.c process.c    \
        protocol.c subnet.c tincd.c
 
-INCLUDES = -I$(top_builddir) -I$(top_srcdir)/lib -I$(top_srcdir)/intl
+INCLUDES = @INCLUDES@ -I$(top_builddir) -I$(top_srcdir)/lib -I$(top_srcdir)/intl
 
 noinst_HEADERS = conf.h connection.h meta.h net.h netutl.h process.h   \
        protocol.h subnet.h
@@ -20,3 +20,6 @@ localedir = $(datadir)/locale
 
 CFLAGS = @CFLAGS@ -DPKGLIBDIR=$(pkglibdir) -DCONFDIR=\"$(sysconfdir)\" \
        -DLOCALEDIR=\"$(localedir)\" -DLOCALSTATEDIR=\"$(localstatedir)\"
+
+lint: $(tincd_SOURCES)
+       lclint -nullassign -nullret +trytorecover +posixlib -skipansiheaders -skipposixheaders +gnuextensions -I/usr/include -I/usr/lib/gcc-lib/i386-linux/2.95.2/include -I. -I/home/zarq/p/tinc/cvs/cabal/src -I.. -I.. -I/home/zarq/p/tinc/cvs/cabal/lib -I/home/zarq/p/tinc/cvs/cabal/intl -D_POSIX_SOURCE -D__ELF__ -Dunix -D__i386__ -Dlinux -DHAVE_CONFIG_H -DPKGLIBDIR=/usr/local/lib/tinc -DCONFDIR=\"/usr/local/etc\" -DLOCALEDIR=\"/usr/local/share/locale\" $^