- Updated CVS_CREATED to remove intl/ directory and some other
[tinc] / src / Makefile.am
index 4e11d26..1f6b44b 100644 (file)
@@ -1,14 +1,14 @@
 ## Produce this file with automake to get Makefile.in
-# $Id: Makefile.am,v 1.4.4.7 2000/11/16 17:54:27 zarq Exp $
+# $Id: Makefile.am,v 1.4.4.12 2001/02/11 11:50:09 guus Exp $
 
 sbin_PROGRAMS = tincd
 
-tincd_SOURCES = conf.c connlist.c meta.c net.c netutl.c process.c      \
+tincd_SOURCES = conf.c connection.c meta.c net.c netutl.c process.c    \
        protocol.c subnet.c tincd.c
 
 INCLUDES = @INCLUDES@ -I$(top_builddir) -I$(top_srcdir)/lib -I$(top_srcdir)/intl
 
-noinst_HEADERS = conf.h connlist.h meta.h net.h netutl.h process.h     \
+noinst_HEADERS = conf.h connection.h meta.h net.h netutl.h process.h   \
        protocol.h subnet.h
 
 LIBS = @LIBS@ @INTLLIBS@
@@ -18,5 +18,8 @@ tincd_LDADD = \
 
 localedir = $(datadir)/locale
 
-CFLAGS = @CFLAGS@ -DPKGLIBDIR=$(pkglibdir) -DCONFDIR=\"@sysconfdir@\"  \
-       -DLOCALEDIR=\"$(localedir)\"
+CFLAGS = @CFLAGS@ -DPKGLIBDIR=$(pkglibdir) -DCONFDIR=\"$(sysconfdir)\" \
+       -DLOCALEDIR=\"$(localedir)\" -DLOCALSTATEDIR=\"$(localstatedir)\"
+
+lint: $(tincd_SOURCES)
+       lclint -nullassign -nullret +trytorecover +posixlib -skipansiheaders -skipposixheaders +gnuextensions -I/usr/include -I/usr/lib/gcc-lib/i386-linux/2.95.2/include -I. -I/home/zarq/p/tinc/cvs/cabal/src -I.. -I.. -I/home/zarq/p/tinc/cvs/cabal/lib -I/home/zarq/p/tinc/cvs/cabal/intl -D_POSIX_SOURCE -D__ELF__ -Dunix -D__i386__ -Dlinux -DHAVE_CONFIG_H -DPKGLIBDIR=/usr/local/lib/tinc -DCONFDIR=\"/usr/local/etc\" -DLOCALEDIR=\"/usr/local/share/locale\" $^