Use SPTPS when ExperimentalProtocol is enabled.
[tinc] / src / Makefile.am
index ba8b347..255ce34 100644 (file)
@@ -8,7 +8,7 @@ tincd_SOURCES = \
        utils.c getopt.c getopt1.c list.c splay_tree.c dropin.c fake-getaddrinfo.c fake-getnameinfo.c \
        buffer.c conf.c connection.c control.c edge.c graph.c logger.c meta.c net.c net_packet.c net_setup.c \
        net_socket.c netutl.c node.c process.c protocol.c protocol_auth.c protocol_edge.c protocol_misc.c \
-       protocol_key.c protocol_subnet.c route.c subnet.c tincd.c \
+       protocol_key.c protocol_subnet.c route.c sptps.c subnet.c tincd.c \
        dummy_device.c raw_socket_device.c
        
 if UML
@@ -31,7 +31,7 @@ nodist_tincctl_SOURCES = \
 
 sptps_test_SOURCES = \
        logger.c cipher.c crypto.c ecdh.c ecdsa.c digest.c prf.c \
-       sptps.c sptps_test.c
+       sptps.c sptps_test.c utils.c
 
 if TUNEMU
 tincd_SOURCES += bsd/tunemu.c