Add ECDSA key generation.
[tinc] / src / Makefile.am
index a7c56c8..3303374 100644 (file)
@@ -11,7 +11,7 @@ tincd_SOURCES = \
        protocol_key.c protocol_subnet.c route.c subnet.c tincd.c
 
 nodist_tincd_SOURCES = \
-       device.c cipher.c crypto.c ecdh.c digest.c prf.c rsa.c
+       device.c cipher.c crypto.c ecdh.c ecdsagen.c digest.c prf.c rsa.c
 
 tincctl_SOURCES = \
        utils.c getopt.c getopt1.c dropin.c \
@@ -32,7 +32,7 @@ INCLUDES = @INCLUDES@ -I$(top_builddir)
 
 noinst_HEADERS = \
        xalloc.h utils.h getopt.h list.h splay_tree.h dropin.h fake-getaddrinfo.h fake-getnameinfo.h fake-gai-errnos.h ipv6.h ipv4.h ethernet.h \
-       buffer.h cipher.h conf.h connection.h control.h control_common.h crypto.h device.h ecdh.h digest.h edge.h graph.h logger.h meta.h net.h netutl.h node.h prf.h process.h \
+       buffer.h cipher.h conf.h connection.h control.h control_common.h crypto.h device.h digest.h ecdh.h ecdsagen.c edge.h graph.h logger.h meta.h net.h netutl.h node.h prf.h process.h \
        protocol.h route.h rsa.h rsagen.h subnet.h tincctl.h top.h bsd/tunemu.h
 
 LIBS = @LIBS@ @LIBGCRYPT_LIBS@