Merge branch 'master' into 1.1
[tinc] / src / Makefile.am
index ed110e9..3af74ca 100644 (file)
@@ -1,5 +1,4 @@
 ## Produce this file with automake to get Makefile.in
-# $Id: Makefile.am,v 1.4.4.33 2003/08/02 15:13:08 guus Exp $
 
 sbin_PROGRAMS = tincd tincctl
 
@@ -11,6 +10,10 @@ tincd_SOURCES = cipher.c conf.c connection.c control.c crypto.c digest.c edge.c
 
 tincctl_SOURCES = tincctl.c rsagen.c
 
+if TUNEMU
+tincd_SOURCES += bsd/tunemu.c
+endif
+
 nodist_tincd_SOURCES = device.c
 
 DEFAULT_INCLUDES =
@@ -18,9 +21,13 @@ DEFAULT_INCLUDES =
 INCLUDES = @INCLUDES@ -I$(top_builddir) -I$(top_srcdir)/lib
 
 noinst_HEADERS = cipher.h conf.h connection.h control.h crypto.h device.h digest.h edge.h graph.h logger.h meta.h net.h netutl.h node.h process.h      \
-       protocol.h route.h rsa.h rsagen.h subnet.h
+       protocol.h route.h rsa.h rsagen.h subnet.h bsd/tunemu.h
+
+LIBS = @LIBS@ @LIBGCRYPT_LIBS@
 
-LIBS = @LIBS@ @LIBGCRYPT_LIBS@ @LIBINTL@
+if TUNEMU
+LIBS += -lpcap
+endif
 
 tincd_LDADD = \
        $(top_builddir)/lib/libvpn.a