Fixes for bugs in src/Makefile.am and tincctl.c introduced by cfe9285adf391ab66faeb5d...
[tinc] / src / Makefile.am
index 5c8a841..52f38e4 100644 (file)
@@ -203,7 +203,8 @@ sptps_speed_SOURCES += \
        openssl/crypto.c \
        openssl/digest.c openssl/digest.h \
        openssl/prf.c
-elif GCRYPT
+else
+if GCRYPT
 tincd_SOURCES += \
        gcrypt/cipher.c \
        gcrypt/crypto.c \
@@ -244,6 +245,7 @@ sptps_speed_SOURCES += \
        nolegacy/crypto.c \
        nolegacy/prf.c
 endif
+endif
 
 tinc_LDADD = $(READLINE_LIBS) $(CURSES_LIBS)
 sptps_speed_LDADD = -lrt