Fix typo in Makefile.am.
[tinc] / src / Makefile.am
index 7de9ecb..53dd68d 100644 (file)
@@ -5,8 +5,8 @@ sbin_PROGRAMS = tincd tinc sptps_test sptps_keypair
 ## Make sure version.c is always rebuilt with the latest git information
 .PHONY: ${srcdir}/version.c version_git.h
 version_git.h:
-       echo >$@
-       -(cd $(srcdir) && git describe) && echo '#define GIT_DESCRIPTION "'`(cd $(srcdir) && git describe) | sed 's/release-//'`'"' >$@
+       $(AM_V_GEN)echo >$@
+       @-(cd $(srcdir) && git describe >/dev/null) && echo '#define GIT_DESCRIPTION "'`(cd $(srcdir) && git describe) | sed 's/release-//'`'"' >$@ ||:
 ${srcdir}/version.c: version_git.h
 
 if LINUX
@@ -98,8 +98,6 @@ tincd_SOURCES = \
 
 tinc_SOURCES = \
        dropin.c dropin.h \
-       getopt.c getopt.h \
-       getopt1.c \
        fsck.c fsck.h \
        info.c info.h \
        invitation.c invitation.h \
@@ -154,7 +152,7 @@ tincd_SOURCES += \
        getopt1.c
 tinc_SOURCES += \
        getopt.c getopt.h \
-       getopt1.cendif
+       getopt1.c
 sptps_test_SOURCES += \
        getopt.c getopt.h \
        getopt1.c