Add an invitation protocol.
[tinc] / src / Makefile.am
index 4e7de25..57e0b69 100644 (file)
@@ -5,18 +5,67 @@ sbin_PROGRAMS = tincd tinc sptps_test
 EXTRA_DIST = linux bsd solaris cygwin mingw openssl gcrypt
 
 tincd_SOURCES = \
-       utils.c getopt.c getopt1.c list.c splay_tree.c dropin.c fake-getaddrinfo.c fake-getnameinfo.c hash.c \
-       buffer.c conf.c connection.c control.c edge.c graph.c logger.c meta.c net.c net_packet.c net_setup.c \
-       net_socket.c netutl.c node.c process.c protocol.c protocol_auth.c protocol_edge.c protocol_misc.c \
-       protocol_key.c protocol_subnet.c route.c sptps.c subnet.c subnet_parse.c event.c tincd.c \
-       dummy_device.c raw_socket_device.c multicast_device.c names.c
+       buffer.c \
+       conf.c \
+       connection.c \
+       control.c \
+       dropin.c \
+       dummy_device.c \
+       edge.c \
+       event.c \
+       fake-getaddrinfo.c \
+       fake-getnameinfo.c \
+       getopt.c \
+       getopt1.c \
+       graph.c \
+       hash.c \
+       list.c \
+       logger.c \
+       meta.c \
+       multicast_device.c \
+       names.c \
+       net.c \
+       net_packet.c \
+       net_setup.c \
+       net_socket.c \
+       netutl.c \
+       node.c \
+       process.c \
+       protocol.c \
+       protocol_auth.c \
+       protocol_edge.c \
+       protocol_key.c \
+       protocol_misc.c \
+       protocol_subnet.c \
+       raw_socket_device.c \
+       route.c \
+       splay_tree.c \
+       sptps.c \
+       subnet.c \
+       subnet_parse.c \
+       tincd.c \
+       utils.c
 
 tinc_SOURCES = \
-       utils.c getopt.c getopt1.c dropin.c \
-       info.c list.c subnet_parse.c tincctl.c top.c names.c
+       dropin.c \
+       getopt.c \
+       getopt1.c \
+       info.c \
+       invitation.c \
+       list.c \
+       names.c \
+       netutl.c \
+       sptps.c \
+       subnet_parse.c \
+       tincctl.c \
+       top.c \
+       utils.c
 
 sptps_test_SOURCES = \
-       logger.c sptps.c sptps_test.c utils.c
+       logger.c \
+       sptps.c \
+       sptps_test.c \
+       utils.c
 
 ## Conditionally compile device drivers
        
@@ -55,22 +104,27 @@ if OPENSSL
 tincd_SOURCES += \
        openssl/cipher.c \
        openssl/crypto.c \
+       openssl/digest.c \
        openssl/ecdh.c \
        openssl/ecdsa.c \
-       openssl/digest.c \
        openssl/prf.c \
        openssl/rsa.c
 tinc_SOURCES += \
+       openssl/cipher.c \
+       openssl/crypto.c \
+       openssl/digest.c \
+       openssl/ecdh.c \
        openssl/ecdsa.c \
        openssl/ecdsagen.c \
+       openssl/prf.c \
        openssl/rsa.c \
        openssl/rsagen.c
 sptps_test_SOURCES += \
        openssl/cipher.c \
        openssl/crypto.c \
+       openssl/digest.c \
        openssl/ecdh.c \
        openssl/ecdsa.c \
-       openssl/digest.c \
        openssl/prf.c
 endif
 
@@ -78,32 +132,80 @@ if GCRYPT
 tincd_SOURCES += \
        gcrypt/cipher.c \
        gcrypt/crypto.c \
+       gcrypt/digest.c \
        gcrypt/ecdh.c \
        gcrypt/ecdsa.c \
-       gcrypt/digest.c \
        gcrypt/prf.c \
        gcrypt/rsa.c
 tinc_SOURCES += \
+       gcrypt/cipher.c \
+       gcrypt/crypto.c \
+       gcrypt/digest.c \
+       gcrypt/ecdh.c \
        gcrypt/ecdsa.c \
        gcrypt/ecdsagen.c \
+       gcrypt/prf.c \
        gcrypt/rsa.c \
        gcrypt/rsagen.c
 sptps_test_SOURCES += \
        gcrypt/cipher.c \
        gcrypt/crypto.c \
+       gcrypt/digest.c \
        gcrypt/ecdh.c \
        gcrypt/ecdsa.c \
-       gcrypt/digest.c \
        gcrypt/prf.c
 endif
 
 tinc_LDADD = $(READLINE_LIBS) $(CURSES_LIBS)
 
 noinst_HEADERS = \
-       xalloc.h utils.h getopt.h list.h splay_tree.h dropin.h fake-getaddrinfo.h fake-getnameinfo.h fake-gai-errnos.h ipv6.h ipv4.h ethernet.h \
-       buffer.h conf.h connection.h control.h control_common.h device.h edge.h graph.h info.h logger.h meta.h net.h netutl.h node.h process.h \
-       protocol.h route.h subnet.h sptps.h tincctl.h top.h hash.h event.h names.h have.h system.h \
-       cipher.h crypto.h digest.h ecdh.h ecdsa.h ecdsagen.h prf.h rsa.h rsagen.h
+       buffer.h \
+       cipher.h \
+       conf.h \
+       connection.h \
+       control.h \
+       control_common.h \
+       crypto.h \
+       device.h \
+       digest.h \
+       dropin.h \
+       ecdh.h \
+       ecdsa.h \
+       ecdsagen.h \
+       edge.h \
+       ethernet.h \
+       event.h \
+       fake-gai-errnos.h \
+       fake-getaddrinfo.h \
+       fake-getnameinfo.h \
+       getopt.h \
+       graph.h \
+       hash.h \
+       have.h \
+       info.h \
+       ipv4.h \
+       ipv6.h \
+       list.h \
+       logger.h \
+       meta.h \
+       names.h \
+       net.h \
+       netutl.h \
+       node.h \
+       prf.h \
+       process.h \
+       protocol.h \
+       route.h \
+       rsa.h \
+       rsagen.h
+       splay_tree.h \
+       sptps.h \
+       subnet.h \
+       system.h \
+       tincctl.h \
+       top.h \
+       utils.h \
+       xalloc.h
 
 LIBS = @LIBS@ @LIBGCRYPT_LIBS@