Merge branch 'master' of git://tinc-vpn.org/tinc into 1.1
[tinc] / src / Makefile.am
index 4e11d26..60709fb 100644 (file)
@@ -1,22 +1,46 @@
 ## Produce this file with automake to get Makefile.in
-# $Id: Makefile.am,v 1.4.4.7 2000/11/16 17:54:27 zarq Exp $
 
-sbin_PROGRAMS = tincd
+sbin_PROGRAMS = tincd tincctl
 
-tincd_SOURCES = conf.c connlist.c meta.c net.c netutl.c process.c      \
-       protocol.c subnet.c tincd.c
+EXTRA_DIST = linux bsd solaris cygwin mingw raw_socket uml_socket openssl gcrypt
 
-INCLUDES = @INCLUDES@ -I$(top_builddir) -I$(top_srcdir)/lib -I$(top_srcdir)/intl
+tincd_SOURCES = \
+       utils.c getopt.c getopt1.c list.c splay_tree.c dropin.c fake-getaddrinfo.c fake-getnameinfo.c \
+       buffer.c cipher.c conf.c connection.c control.c crypto.c digest.c edge.c graph.c logger.c meta.c net.c net_packet.c net_setup.c \
+       net_socket.c netutl.c node.c process.c protocol.c protocol_auth.c protocol_edge.c protocol_misc.c \
+       protocol_key.c protocol_subnet.c route.c rsa.c subnet.c tincd.c
 
-noinst_HEADERS = conf.h connlist.h meta.h net.h netutl.h process.h     \
-       protocol.h subnet.h
+tincctl_SOURCES = \
+       utils.c getopt.c getopt1.c dropin.c \
+       list.c tincctl.c rsagen.c
 
-LIBS = @LIBS@ @INTLLIBS@
+if TUNEMU
+tincd_SOURCES += bsd/tunemu.c
+endif
 
-tincd_LDADD = \
-       $(top_builddir)/lib/libvpn.a
+if CURSES
+tincctl_SOURCES += top.c
+tincctl_LDADD = $(CURSES_LIBS)
+endif
 
-localedir = $(datadir)/locale
+nodist_tincd_SOURCES = device.c
 
-CFLAGS = @CFLAGS@ -DPKGLIBDIR=$(pkglibdir) -DCONFDIR=\"@sysconfdir@\"  \
-       -DLOCALEDIR=\"$(localedir)\"
+DEFAULT_INCLUDES =
+
+INCLUDES = @INCLUDES@ -I$(top_builddir)
+
+noinst_HEADERS = \
+       xalloc.h utils.h getopt.h list.h splay_tree.h dropin.h fake-getaddrinfo.h fake-getnameinfo.h fake-gai-errnos.h ipv6.h ipv4.h ethernet.h \
+       buffer.h cipher.h conf.h connection.h control.h control_common.h crypto.h device.h digest.h edge.h graph.h logger.h meta.h net.h netutl.h node.h process.h \
+       protocol.h route.h rsa.h rsagen.h subnet.h bsd/tunemu.h
+
+LIBS = @LIBS@ @LIBGCRYPT_LIBS@
+
+if TUNEMU
+LIBS += -lpcap
+endif
+
+AM_CFLAGS = -DCONFDIR=\"$(sysconfdir)\" -DLOCALSTATEDIR=\"$(localstatedir)\" -DSBINDIR=\"$(sbindir)\"
+
+dist-hook:
+       rm -f `find . -type l`