Start of "Simple Peer-To-Peer Security" protocol.
[tinc] / src / Makefile.am
index a7c56c8..61f9a93 100644 (file)
@@ -1,6 +1,6 @@
 ## Produce this file with automake to get Makefile.in
 
-sbin_PROGRAMS = tincd tincctl
+sbin_PROGRAMS = tincd tincctl sptps_test
 
 EXTRA_DIST = linux bsd solaris cygwin mingw raw_socket uml_socket openssl gcrypt
 
@@ -11,14 +11,18 @@ tincd_SOURCES = \
        protocol_key.c protocol_subnet.c route.c subnet.c tincd.c
 
 nodist_tincd_SOURCES = \
-       device.c cipher.c crypto.c ecdh.c digest.c prf.c rsa.c
+       device.c cipher.c crypto.c ecdh.c ecdsa.c digest.c prf.c rsa.c
 
 tincctl_SOURCES = \
        utils.c getopt.c getopt1.c dropin.c \
        list.c tincctl.c top.c
 
 nodist_tincctl_SOURCES = \
-       rsagen.c
+       ecdsagen.c rsagen.c
+
+sptps_test_SOURCES = \
+       logger.c cipher.c crypto.c ecdh.c ecdsa.c digest.c prf.c \
+       sptps.c sptps_test.c
 
 if TUNEMU
 tincd_SOURCES += bsd/tunemu.c
@@ -32,8 +36,11 @@ INCLUDES = @INCLUDES@ -I$(top_builddir)
 
 noinst_HEADERS = \
        xalloc.h utils.h getopt.h list.h splay_tree.h dropin.h fake-getaddrinfo.h fake-getnameinfo.h fake-gai-errnos.h ipv6.h ipv4.h ethernet.h \
-       buffer.h cipher.h conf.h connection.h control.h control_common.h crypto.h device.h ecdh.h digest.h edge.h graph.h logger.h meta.h net.h netutl.h node.h prf.h process.h \
-       protocol.h route.h rsa.h rsagen.h subnet.h tincctl.h top.h bsd/tunemu.h
+       buffer.h conf.h connection.h control.h control_common.h device.h edge.h graph.h logger.h meta.h net.h netutl.h node.h process.h \
+       protocol.h route.h subnet.h tincctl.h top.h bsd/tunemu.h
+
+nodist_noinst_HEADERS = \
+       cipher.h crypto.h ecdh.h ecdsa.h digest.h prf.h rsa.h ecdsagen.h rsagen.h
 
 LIBS = @LIBS@ @LIBGCRYPT_LIBS@