tinc-gui: Reformat codebase according to PEP8
[tinc] / src / Makefile.am
index 52f38e4..63af709 100644 (file)
@@ -2,9 +2,12 @@
 
 sbin_PROGRAMS = tincd tinc sptps_test sptps_keypair
 
-## Make sure version.c is always rebuilt
-.PHONY: version.c
-version.c:
+## Make sure version.c is always rebuilt with the latest git information
+.PHONY: ${srcdir}/version.c version_git.h
+version_git.h:
+       echo >$@
+       -(cd $(srcdir) && git describe) && echo '#define GIT_DESCRIPTION "'`(cd $(srcdir) && git describe) | sed 's/release-//'`'"' >$@
+${srcdir}/version.c: version_git.h
 
 if LINUX
 sbin_PROGRAMS += sptps_speed
@@ -101,6 +104,7 @@ tinc_SOURCES = \
        dropin.c dropin.h \
        getopt.c getopt.h \
        getopt1.c \
+       fsck.c fsck.h \
        info.c info.h \
        invitation.c invitation.h \
        list.c list.h \
@@ -250,10 +254,10 @@ endif
 tinc_LDADD = $(READLINE_LIBS) $(CURSES_LIBS)
 sptps_speed_LDADD = -lrt
 
-LIBS = @LIBS@
+LIBS = @LIBS@ -lm
 
 if TUNEMU
 LIBS += -lpcap
 endif
 
-AM_CFLAGS = -DCONFDIR=\"$(sysconfdir)\" -DLOCALSTATEDIR=\"$(localstatedir)\" -DSBINDIR=\"$(sbindir)\"
+AM_CFLAGS = -DCONFDIR=\"$(sysconfdir)\" -DLOCALSTATEDIR=\"$(localstatedir)\" -DSBINDIR=\"$(sbindir)\" -iquote.