tinc-gui: Reformat codebase according to PEP8
[tinc] / src / Makefile.am
index ec1da98..63af709 100644 (file)
@@ -2,6 +2,13 @@
 
 sbin_PROGRAMS = tincd tinc sptps_test sptps_keypair
 
+## Make sure version.c is always rebuilt with the latest git information
+.PHONY: ${srcdir}/version.c version_git.h
+version_git.h:
+       echo >$@
+       -(cd $(srcdir) && git describe) && echo '#define GIT_DESCRIPTION "'`(cd $(srcdir) && git describe) | sed 's/release-//'`'"' >$@
+${srcdir}/version.c: version_git.h
+
 if LINUX
 sbin_PROGRAMS += sptps_speed
 endif
@@ -18,11 +25,15 @@ ed25519_SOURCES = \
        ed25519/keypair.c \
        ed25519/precomp_data.h \
        ed25519/sc.c ed25519/sc.h \
-       ed25519/seed.c \
        ed25519/sha512.c ed25519/sha512.h \
        ed25519/sign.c \
        ed25519/verify.c
 
+chacha_poly1305_SOURCES = \
+       chacha-poly1305/chacha.c chacha-poly1305/chacha.h \
+       chacha-poly1305/chacha-poly1305.c chacha-poly1305/chacha-poly1305.h \
+       chacha-poly1305/poly1305.c chacha-poly1305/poly1305.h
+
 tincd_SOURCES = \
        buffer.c buffer.h \
        cipher.h \
@@ -83,12 +94,17 @@ tincd_SOURCES = \
        tincd.c \
        utils.c utils.h \
        xalloc.h \
-       $(ed25519_SOURCES)
+       version.c version.h \
+       ed25519/ecdh.c \
+       ed25519/ecdsa.c \
+       $(ed25519_SOURCES) \
+       $(chacha_poly1305_SOURCES)
 
 tinc_SOURCES = \
        dropin.c dropin.h \
        getopt.c getopt.h \
        getopt1.c \
+       fsck.c fsck.h \
        info.c info.h \
        invitation.c invitation.h \
        list.c list.h \
@@ -100,18 +116,27 @@ tinc_SOURCES = \
        tincctl.c tincctl.h \
        top.c top.h \
        utils.c utils.h \
-       $(ed25519_SOURCES)
+       version.c version.h \
+       ed25519/ecdh.c \
+       ed25519/ecdsa.c \
+       ed25519/ecdsagen.c \
+       $(ed25519_SOURCES) \
+       $(chacha_poly1305_SOURCES)
 
 sptps_test_SOURCES = \
        logger.c logger.h \
        sptps.c sptps.h \
        sptps_test.c \
        utils.c utils.h \
-       $(ed25519_SOURCES)
+       ed25519/ecdh.c \
+       ed25519/ecdsa.c \
+       $(ed25519_SOURCES) \
+       $(chacha_poly1305_SOURCES)
 
 sptps_keypair_SOURCES = \
        sptps_keypair.c \
        utils.c utils.h \
+       ed25519/ecdsagen.c \
        $(ed25519_SOURCES)
 
 sptps_speed_SOURCES = \
@@ -119,7 +144,11 @@ sptps_speed_SOURCES = \
        sptps.c sptps.h \
        sptps_speed.c \
        utils.c utils.h \
-       $(ed25519_SOURCES)
+       ed25519/ecdh.c \
+       ed25519/ecdsa.c \
+       ed25519/ecdsagen.c \
+       $(ed25519_SOURCES) \
+       $(chacha_poly1305_SOURCES)
 
 ## Conditionally compile device drivers
        
@@ -159,56 +188,37 @@ tincd_SOURCES += \
        openssl/cipher.c \
        openssl/crypto.c \
        openssl/digest.c openssl/digest.h \
-       ed25519/ecdh.c \
-       ed25519/ecdsa.c \
        openssl/prf.c \
        openssl/rsa.c
 tinc_SOURCES += \
        openssl/cipher.c \
        openssl/crypto.c \
        openssl/digest.c openssl/digest.h \
-       ed25519/ecdh.c \
-       ed25519/ecdsa.c \
-       ed25519/ecdsagen.c \
        openssl/prf.c \
        openssl/rsa.c \
        openssl/rsagen.c
 sptps_test_SOURCES += \
-       openssl/cipher.c \
        openssl/crypto.c \
        openssl/digest.c openssl/digest.h \
-       ed25519/ecdh.c \
-       ed25519/ecdsa.c \
        openssl/prf.c
 sptps_keypair_SOURCES += \
-       openssl/crypto.c \
-       ed25519/ecdsagen.c
+       openssl/crypto.c
 sptps_speed_SOURCES += \
-       openssl/cipher.c \
        openssl/crypto.c \
        openssl/digest.c openssl/digest.h \
-       ed25519/ecdh.c \
-       ed25519/ecdsa.c \
-       ed25519/ecdsagen.c \
        openssl/prf.c
-endif
-
+else
 if GCRYPT
 tincd_SOURCES += \
        gcrypt/cipher.c \
        gcrypt/crypto.c \
        gcrypt/digest.c gcrypt/digest.h \
-       gcrypt/ecdh.c \
-       gcrypt/ecdsa.c \
        gcrypt/prf.c \
        gcrypt/rsa.c
 tinc_SOURCES += \
        gcrypt/cipher.c \
        gcrypt/crypto.c \
        gcrypt/digest.c gcrypt/digest.h \
-       gcrypt/ecdh.c \
-       gcrypt/ecdsa.c \
-       gcrypt/ecdsagen.c \
        gcrypt/prf.c \
        gcrypt/rsa.c \
        gcrypt/rsagen.c
@@ -216,18 +226,38 @@ sptps_test_SOURCES += \
        gcrypt/cipher.c \
        gcrypt/crypto.c \
        gcrypt/digest.c gcrypt/digest.h \
-       gcrypt/ecdh.c \
-       gcrypt/ecdsa.c \
        gcrypt/prf.c
+sptps_keypair_SOURCES += \
+       openssl/crypto.c
+sptps_speed_SOURCES += \
+       openssl/crypto.c \
+       openssl/digest.c openssl/digest.h \
+       openssl/prf.c
+else
+tincd_SOURCES += \
+       nolegacy/crypto.c \
+       nolegacy/prf.c
+tinc_SOURCES += \
+       nolegacy/crypto.c \
+       nolegacy/prf.c
+sptps_test_SOURCES += \
+       nolegacy/crypto.c \
+       nolegacy/prf.c
+sptps_keypair_SOURCES += \
+       nolegacy/crypto.c
+sptps_speed_SOURCES += \
+       nolegacy/crypto.c \
+       nolegacy/prf.c
+endif
 endif
 
 tinc_LDADD = $(READLINE_LIBS) $(CURSES_LIBS)
 sptps_speed_LDADD = -lrt
 
-LIBS = @LIBS@
+LIBS = @LIBS@ -lm
 
 if TUNEMU
 LIBS += -lpcap
 endif
 
-AM_CFLAGS = -DCONFDIR=\"$(sysconfdir)\" -DLOCALSTATEDIR=\"$(localstatedir)\" -DSBINDIR=\"$(sbindir)\"
+AM_CFLAGS = -DCONFDIR=\"$(sysconfdir)\" -DLOCALSTATEDIR=\"$(localstatedir)\" -DSBINDIR=\"$(sbindir)\" -iquote.