BSD make doesn't like .PHONY .c files.
[tinc] / src / Makefile.am
index 08e56ff..6414cdf 100644 (file)
@@ -2,11 +2,8 @@
 
 sbin_PROGRAMS = tincd tinc sptps_test sptps_keypair
 
-## Make sure version.c is always rebuilt with the latest git information
-.PHONY: version.c version_git.h
-version_git.h:
-       echo "#define GIT_DESCRIPTION \"`cd $(@D) && git describe || echo UNKNOWN`\"" >$@
-version.c: version_git.h
+## Make sure version.c is always rebuilt
+.PHONY: version.o
 
 if LINUX
 sbin_PROGRAMS += sptps_speed
@@ -24,7 +21,6 @@ ed25519_SOURCES = \
        ed25519/keypair.c \
        ed25519/precomp_data.h \
        ed25519/sc.c ed25519/sc.h \
-       ed25519/seed.c \
        ed25519/sha512.c ed25519/sha512.h \
        ed25519/sign.c \
        ed25519/verify.c
@@ -94,7 +90,7 @@ tincd_SOURCES = \
        tincd.c \
        utils.c utils.h \
        xalloc.h \
-       version.c version.h version_git.h \
+       version.c version.h \
        $(ed25519_SOURCES) \
        $(chacha_poly1305_SOURCES)
 
@@ -113,7 +109,7 @@ tinc_SOURCES = \
        tincctl.c tincctl.h \
        top.c top.h \
        utils.c utils.h \
-       version.c version.h version_git.h \
+       version.c version.h \
        $(ed25519_SOURCES) \
        $(chacha_poly1305_SOURCES)