BSD make doesn't like .PHONY .c files.
[tinc] / src / Makefile.am
index 1a84098..6414cdf 100644 (file)
@@ -2,6 +2,9 @@
 
 sbin_PROGRAMS = tincd tinc sptps_test sptps_keypair
 
+## Make sure version.c is always rebuilt
+.PHONY: version.o
+
 if LINUX
 sbin_PROGRAMS += sptps_speed
 endif
@@ -18,7 +21,6 @@ ed25519_SOURCES = \
        ed25519/keypair.c \
        ed25519/precomp_data.h \
        ed25519/sc.c ed25519/sc.h \
-       ed25519/seed.c \
        ed25519/sha512.c ed25519/sha512.h \
        ed25519/sign.c \
        ed25519/verify.c
@@ -88,6 +90,7 @@ tincd_SOURCES = \
        tincd.c \
        utils.c utils.h \
        xalloc.h \
+       version.c version.h \
        $(ed25519_SOURCES) \
        $(chacha_poly1305_SOURCES)
 
@@ -106,6 +109,7 @@ tinc_SOURCES = \
        tincctl.c tincctl.h \
        top.c top.h \
        utils.c utils.h \
+       version.c version.h \
        $(ed25519_SOURCES) \
        $(chacha_poly1305_SOURCES)