Add fd_device
[tinc] / src / Makefile.am
index 0e95418..794e420 100644 (file)
@@ -1,6 +1,9 @@
 ## Produce this file with automake to get Makefile.in
 
-sbin_PROGRAMS = tincd tinc sptps_test sptps_keypair
+sbin_PROGRAMS = tincd tinc
+EXTRA_PROGRAMS = sptps_test sptps_keypair
+
+CLEANFILES = version_git.h
 
 .PHONY: version-stamp
 version-stamp:
@@ -10,8 +13,13 @@ version_git.h: version-stamp
        @-(cd $(srcdir) && git describe 2>/dev/null >/dev/null) && echo '#define GIT_DESCRIPTION "'`(cd $(srcdir) && git describe) | sed 's/release-//'`'"' >$@ ||:
 ${srcdir}/version.c: version_git.h
 
+## Now a hack to appease some versions of BSD make that don't understand that "./foo" is the same as "foo".
+if BSD
+version.c: ${srcdir}/version.c
+endif
+
 if LINUX
-sbin_PROGRAMS += sptps_speed
+EXTRA_PROGRAMS += sptps_speed
 endif
 
 ed25519_SOURCES = \
@@ -51,9 +59,7 @@ tincd_SOURCES = \
        edge.c edge.h \
        ethernet.h \
        event.c event.h \
-       fake-gai-errnos.h \
-       fake-getaddrinfo.c fake-getaddrinfo.h \
-       fake-getnameinfo.c fake-getnameinfo.h \
+       fd_device.c \
        graph.c graph.h \
        hash.c hash.h \
        have.h \
@@ -100,6 +106,7 @@ tincd_SOURCES = \
 tinc_SOURCES = \
        dropin.c dropin.h \
        fsck.c fsck.h \
+       ifconfig.c ifconfig.h \
        info.c info.h \
        invitation.c invitation.h \
        list.c list.h \