Add fd_device
[tinc] / src / Makefile.am
index 7de9ecb..794e420 100644 (file)
@@ -1,16 +1,25 @@
 ## Produce this file with automake to get Makefile.in
 
-sbin_PROGRAMS = tincd tinc sptps_test sptps_keypair
+sbin_PROGRAMS = tincd tinc
+EXTRA_PROGRAMS = sptps_test sptps_keypair
 
-## Make sure version.c is always rebuilt with the latest git information
-.PHONY: ${srcdir}/version.c version_git.h
-version_git.h:
-       echo >$@
-       -(cd $(srcdir) && git describe) && echo '#define GIT_DESCRIPTION "'`(cd $(srcdir) && git describe) | sed 's/release-//'`'"' >$@
+CLEANFILES = version_git.h
+
+.PHONY: version-stamp
+version-stamp:
+
+version_git.h: version-stamp
+       $(AM_V_GEN)echo >$@
+       @-(cd $(srcdir) && git describe 2>/dev/null >/dev/null) && echo '#define GIT_DESCRIPTION "'`(cd $(srcdir) && git describe) | sed 's/release-//'`'"' >$@ ||:
 ${srcdir}/version.c: version_git.h
 
+## Now a hack to appease some versions of BSD make that don't understand that "./foo" is the same as "foo".
+if BSD
+version.c: ${srcdir}/version.c
+endif
+
 if LINUX
-sbin_PROGRAMS += sptps_speed
+EXTRA_PROGRAMS += sptps_speed
 endif
 
 ed25519_SOURCES = \
@@ -50,9 +59,7 @@ tincd_SOURCES = \
        edge.c edge.h \
        ethernet.h \
        event.c event.h \
-       fake-gai-errnos.h \
-       fake-getaddrinfo.c fake-getaddrinfo.h \
-       fake-getnameinfo.c fake-getnameinfo.h \
+       fd_device.c \
        graph.c graph.h \
        hash.c hash.h \
        have.h \
@@ -98,9 +105,8 @@ tincd_SOURCES = \
 
 tinc_SOURCES = \
        dropin.c dropin.h \
-       getopt.c getopt.h \
-       getopt1.c \
        fsck.c fsck.h \
+       ifconfig.c ifconfig.h \
        info.c info.h \
        invitation.c invitation.h \
        list.c list.h \
@@ -154,7 +160,7 @@ tincd_SOURCES += \
        getopt1.c
 tinc_SOURCES += \
        getopt.c getopt.h \
-       getopt1.cendif
+       getopt1.c
 sptps_test_SOURCES += \
        getopt.c getopt.h \
        getopt1.c