Support autoconf's --runstatedir option.
[tinc] / src / Makefile.am
index ebd52ab..7b3dd97 100644 (file)
@@ -14,11 +14,8 @@ tincd_SOURCES = \
        edge.c edge.h \
        ethernet.h \
        event.c event.h \
-       fake-gai-errnos.h \
        fake-getaddrinfo.c fake-getaddrinfo.h \
        fake-getnameinfo.c fake-getnameinfo.h \
-       getopt.c getopt.h \
-       getopt1.c \
        graph.c graph.h \
        ipv4.h \
        ipv6.h \
@@ -46,8 +43,13 @@ tincd_SOURCES = \
        subnet.c subnet.h \
        tincd.c \
        utils.c utils.h \
-       xalloc.h \
-       xmalloc.c
+       xalloc.h
+
+if !GETOPT
+tincd_SOURCES += \
+       getopt.c getopt.h \
+       getopt1.c
+endif
 
 if LINUX
 tincd_SOURCES += linux/device.c
@@ -84,4 +86,4 @@ if TUNEMU
 LIBS += -lpcap
 endif
 
-AM_CPPFLAGS = -DCONFDIR=\"$(sysconfdir)\" -DLOCALSTATEDIR=\"$(localstatedir)\"
+AM_CPPFLAGS = -DCONFDIR=\"$(sysconfdir)\" -DRUNSTATEDIR=\"$(runstatedir)\" -DLOCALSTATEDIR=\"$(localstatedir)\" -I $(abs_top_builddir)/