Replace pointers to cipher_t/digest_t in connection_t with structs.
[tinc] / src / Makefile.am
index 792dd78..a1d3423 100644 (file)
@@ -216,13 +216,13 @@ endif
 
 if OPENSSL
 tincd_SOURCES += \
-       openssl/cipher.c \
+       openssl/cipher.c openssl/cipher.h \
        openssl/crypto.c \
        openssl/digest.c openssl/digest.h \
        openssl/prf.c \
        openssl/rsa.c
 tinc_SOURCES += \
-       openssl/cipher.c \
+       openssl/cipher.c openssl/cipher.h \
        openssl/crypto.c \
        openssl/digest.c openssl/digest.h \
        openssl/prf.c \
@@ -282,6 +282,13 @@ sptps_speed_SOURCES += \
 endif
 endif
 
+if WITH_LEGACY_PROTOCOL
+tinc_SOURCES        += digest.c
+tincd_SOURCES       += digest.c cipher.c
+sptps_test_SOURCES  += digest.c
+sptps_speed_SOURCES += digest.c
+endif
+
 if MINIUPNPC
 tincd_SOURCES += upnp.h upnp.c
 tincd_LDADD = $(MINIUPNPC_LIBS)