Finish crypto wrapping. Also provide wrappers for OpenSSL.
[tinc] / src / Makefile.am
index 5259ff7..a318dcd 100644 (file)
@@ -5,7 +5,7 @@ sbin_PROGRAMS = tincd tincctl
 
 EXTRA_DIST = linux/device.c bsd/device.c solaris/device.c cygwin/device.c mingw/device.c mingw/common.h raw_socket/device.c uml_socket/device.c
 
-tincd_SOURCES = conf.c connection.c control.c edge.c graph.c logger.c meta.c net.c net_packet.c net_setup.c    \
+tincd_SOURCES = cipher.c conf.c connection.c control.c crypto.c digest.c edge.c graph.c logger.c meta.c net.c net_packet.c net_setup.c \
        net_socket.c netutl.c node.c process.c protocol.c protocol_auth.c protocol_edge.c protocol_misc.c       \
        protocol_key.c protocol_subnet.c route.c rsa.c subnet.c tincd.c
 
@@ -17,14 +17,13 @@ DEFAULT_INCLUDES =
 
 INCLUDES = @INCLUDES@ -I$(top_builddir) -I$(top_srcdir)/lib
 
-noinst_HEADERS = conf.h connection.h control.h device.h edge.h graph.h logger.h meta.h net.h netutl.h node.h process.h \
+noinst_HEADERS = cipher.h conf.h connection.h control.h crypto.h device.h digest.h edge.h graph.h logger.h meta.h net.h netutl.h node.h process.h      \
        protocol.h route.h rsa.h subnet.h
 
 LIBS = @LIBS@ @LIBINTL@
 
 tincd_LDADD = \
-       $(top_builddir)/lib/libvpn.a \
-       $(LIBGCRYPT_LIBS)
+       $(top_builddir)/lib/libvpn.a
 
 tincctl_LDADD = \
        $(top_builddir)/lib/libvpn.a
@@ -32,7 +31,6 @@ tincctl_LDADD = \
 localedir = $(datadir)/locale
 
 AM_CFLAGS = @CFLAGS@ -DCONFDIR=\"$(sysconfdir)\" -DLOCALEDIR=\"$(localedir)\" -DLOCALSTATEDIR=\"$(localstatedir)\"
-tinc_CPPFLAGS = $(LIBGCRYPT_CFLAGS)
 
 dist-hook:
        rm -f `find . -type l`