"tincctl info" gives more human readable information about nodes or subnets.
[tinc] / src / Makefile.am
index 255ce34..b0f7791 100644 (file)
@@ -8,8 +8,8 @@ tincd_SOURCES = \
        utils.c getopt.c getopt1.c list.c splay_tree.c dropin.c fake-getaddrinfo.c fake-getnameinfo.c \
        buffer.c conf.c connection.c control.c edge.c graph.c logger.c meta.c net.c net_packet.c net_setup.c \
        net_socket.c netutl.c node.c process.c protocol.c protocol_auth.c protocol_edge.c protocol_misc.c \
-       protocol_key.c protocol_subnet.c route.c sptps.c subnet.c tincd.c \
-       dummy_device.c raw_socket_device.c
+       protocol_key.c protocol_subnet.c route.c sptps.c subnet.c subnet_parse.c tincd.c \
+       dummy_device.c raw_socket_device.c multicast_device.c
        
 if UML
 tincd_SOURCES += uml_device.c
@@ -24,7 +24,7 @@ nodist_tincd_SOURCES = \
 
 tincctl_SOURCES = \
        utils.c getopt.c getopt1.c dropin.c \
-       list.c tincctl.c top.c
+       info.c list.c subnet_parse.c tincctl.c top.c
 
 nodist_tincctl_SOURCES = \
        ecdsagen.c rsagen.c