"tincctl info" gives more human readable information about nodes or subnets.
[tinc] / src / Makefile.am
index 7ef3ab3..b0f7791 100644 (file)
@@ -1,19 +1,63 @@
 ## Produce this file with automake to get Makefile.in
-# $Id: Makefile.am,v 1.4.4.5 2000/11/02 21:26:51 zarq Exp $
 
-sbin_PROGRAMS = tincd
+sbin_PROGRAMS = tincd tincctl sptps_test
 
-tincd_SOURCES = conf.c connlist.c meta.c net.c netutl.c protocol.c subnet.c tincd.c
+EXTRA_DIST = linux bsd solaris cygwin mingw openssl gcrypt
 
-INCLUDES = -I$(top_builddir) -I$(top_srcdir)/lib -I$(top_srcdir)/intl
+tincd_SOURCES = \
+       utils.c getopt.c getopt1.c list.c splay_tree.c dropin.c fake-getaddrinfo.c fake-getnameinfo.c \
+       buffer.c conf.c connection.c control.c edge.c graph.c logger.c meta.c net.c net_packet.c net_setup.c \
+       net_socket.c netutl.c node.c process.c protocol.c protocol_auth.c protocol_edge.c protocol_misc.c \
+       protocol_key.c protocol_subnet.c route.c sptps.c subnet.c subnet_parse.c tincd.c \
+       dummy_device.c raw_socket_device.c multicast_device.c
+       
+if UML
+tincd_SOURCES += uml_device.c
+endif
 
-noinst_HEADERS = conf.h connlist.h meta.h net.h netutl.h protocol.h subnet.h
+if VDE
+tincd_SOURCES += vde_device.c
+endif
 
-LIBS = @LIBS@ @INTLLIBS@
+nodist_tincd_SOURCES = \
+       device.c cipher.c crypto.c ecdh.c ecdsa.c digest.c prf.c rsa.c
 
-tincd_LDADD = \
-       $(top_builddir)/lib/libvpn.a
+tincctl_SOURCES = \
+       utils.c getopt.c getopt1.c dropin.c \
+       info.c list.c subnet_parse.c tincctl.c top.c
 
-localedir = $(datadir)/locale
+nodist_tincctl_SOURCES = \
+       ecdsagen.c rsagen.c
 
-CFLAGS = @CFLAGS@ -DPKGLIBDIR=$(pkglibdir) -DCONFDIR=\"@sysconfdir@\" -DLOCALEDIR=\"$(localedir)\"
+sptps_test_SOURCES = \
+       logger.c cipher.c crypto.c ecdh.c ecdsa.c digest.c prf.c \
+       sptps.c sptps_test.c utils.c
+
+if TUNEMU
+tincd_SOURCES += bsd/tunemu.c
+endif
+
+tincctl_LDADD = $(CURSES_LIBS)
+
+DEFAULT_INCLUDES =
+
+INCLUDES = @INCLUDES@ -I$(top_builddir)
+
+noinst_HEADERS = \
+       xalloc.h utils.h getopt.h list.h splay_tree.h dropin.h fake-getaddrinfo.h fake-getnameinfo.h fake-gai-errnos.h ipv6.h ipv4.h ethernet.h \
+       buffer.h conf.h connection.h control.h control_common.h device.h edge.h graph.h logger.h meta.h net.h netutl.h node.h process.h \
+       protocol.h route.h subnet.h tincctl.h top.h bsd/tunemu.h
+
+nodist_noinst_HEADERS = \
+       cipher.h crypto.h ecdh.h ecdsa.h digest.h prf.h rsa.h ecdsagen.h rsagen.h
+
+LIBS = @LIBS@ @LIBGCRYPT_LIBS@
+
+if TUNEMU
+LIBS += -lpcap
+endif
+
+AM_CFLAGS = -DCONFDIR=\"$(sysconfdir)\" -DLOCALSTATEDIR=\"$(localstatedir)\" -DSBINDIR=\"$(sbindir)\"
+
+dist-hook:
+       rm -f `find . -type l`