Use conditional compilation for device.c.
[tinc] / src / Makefile.am
index 3bd8646..c1f51f1 100644 (file)
@@ -1,6 +1,6 @@
 ## Produce this file with automake to get Makefile.in
 
-sbin_PROGRAMS = tincd tincctl sptps_test
+sbin_PROGRAMS = tincd tinc sptps_test
 
 EXTRA_DIST = linux bsd solaris cygwin mingw openssl gcrypt
 
@@ -8,9 +8,31 @@ tincd_SOURCES = \
        utils.c getopt.c getopt1.c list.c splay_tree.c dropin.c fake-getaddrinfo.c fake-getnameinfo.c hash.c \
        buffer.c conf.c connection.c control.c edge.c graph.c logger.c meta.c net.c net_packet.c net_setup.c \
        net_socket.c netutl.c node.c process.c protocol.c protocol_auth.c protocol_edge.c protocol_misc.c \
-       protocol_key.c protocol_subnet.c route.c sptps.c subnet.c subnet_parse.c tincd.c \
-       dummy_device.c raw_socket_device.c multicast_device.c
+       protocol_key.c protocol_subnet.c route.c sptps.c subnet.c subnet_parse.c event.c tincd.c \
+       dummy_device.c raw_socket_device.c multicast_device.c names.c
+
+## Conditionally compile device drivers
        
+if LINUX
+tincd_SOURCES += linux/device.c
+endif
+
+if BSD
+tincd_SOURCES += bsd/device.c
+endif
+
+if SOLARIS
+tincd_SOURCES += solaris/device.c
+endif
+
+if MINGW
+tincd_SOURCES += mingw/device.c
+endif
+
+if CYGWIN
+tincd_SOURCES += cygwin/device.c
+endif
+
 if UML
 tincd_SOURCES += uml_device.c
 endif
@@ -20,13 +42,13 @@ tincd_SOURCES += vde_device.c
 endif
 
 nodist_tincd_SOURCES = \
-       device.c cipher.c crypto.c ecdh.c ecdsa.c digest.c prf.c rsa.c
+       cipher.c crypto.c ecdh.c ecdsa.c digest.c prf.c rsa.c
 
-tincctl_SOURCES = \
+tinc_SOURCES = \
        utils.c getopt.c getopt1.c dropin.c \
-       info.c list.c subnet_parse.c tincctl.c top.c
+       info.c list.c subnet_parse.c tincctl.c top.c names.c
 
-nodist_tincctl_SOURCES = \
+nodist_tinc_SOURCES = \
        ecdsagen.c rsagen.c
 
 sptps_test_SOURCES = \
@@ -37,16 +59,16 @@ if TUNEMU
 tincd_SOURCES += bsd/tunemu.c
 endif
 
-tincctl_LDADD = $(READLINE_LIBS) $(CURSES_LIBS)
+tinc_LDADD = $(READLINE_LIBS) $(CURSES_LIBS)
 
 DEFAULT_INCLUDES =
 
-INCLUDES = @INCLUDES@ -I$(top_builddir)
+INCLUDES = @INCLUDES@
 
 noinst_HEADERS = \
        xalloc.h utils.h getopt.h list.h splay_tree.h dropin.h fake-getaddrinfo.h fake-getnameinfo.h fake-gai-errnos.h ipv6.h ipv4.h ethernet.h \
        buffer.h conf.h connection.h control.h control_common.h device.h edge.h graph.h info.h logger.h meta.h net.h netutl.h node.h process.h \
-       protocol.h route.h subnet.h sptps.h tincctl.h top.h bsd/tunemu.h hash.h
+       protocol.h route.h subnet.h sptps.h tincctl.h top.h bsd/tunemu.h hash.h event.h names.h
 
 nodist_noinst_HEADERS = \
        cipher.h crypto.h ecdh.h ecdsa.h digest.h prf.h rsa.h ecdsagen.h rsagen.h