Regenerate build date and time every time tinc is built.
[tinc] / src / Makefile.am
index 1a84098..c48e3fd 100644 (file)
@@ -2,6 +2,9 @@
 
 sbin_PROGRAMS = tincd tinc sptps_test sptps_keypair
 
+## Make sure version.c is always rebuilt
+.PHONY: version.c
+
 if LINUX
 sbin_PROGRAMS += sptps_speed
 endif
@@ -88,6 +91,7 @@ tincd_SOURCES = \
        tincd.c \
        utils.c utils.h \
        xalloc.h \
+       version.c version.h \
        $(ed25519_SOURCES) \
        $(chacha_poly1305_SOURCES)
 
@@ -106,6 +110,7 @@ tinc_SOURCES = \
        tincctl.c tincctl.h \
        top.c top.h \
        utils.c utils.h \
+       version.c version.h \
        $(ed25519_SOURCES) \
        $(chacha_poly1305_SOURCES)