Extract common logic in OpenSSL-specific code
[tinc] / src / Makefile.am
index 306bbc4..dc124b1 100644 (file)
@@ -2,10 +2,13 @@
 
 sbin_PROGRAMS = tincd tinc
 check_PROGRAMS = sptps_test sptps_keypair
-EXTRA_PROGRAMS = sptps_test sptps_keypair
+EXTRA_PROGRAMS = $(check_PROGRAMS)
 
 CLEANFILES = version_git.h
 
+.PHONY: extra
+extra: $(EXTRA_PROGRAMS)
+
 .PHONY: version-stamp
 version-stamp:
 
@@ -52,6 +55,7 @@ tincd_SOURCES = \
        autoconnect.c autoconnect.h \
        buffer.c buffer.h \
        cipher.h \
+       compression.h \
        conf.c conf.h \
        conf_net.c conf_net.h \
        connection.c connection.h \
@@ -70,7 +74,7 @@ tincd_SOURCES = \
        event.c event.h \
        fd_device.c \
        graph.c graph.h \
-       hash.c hash.h \
+       hash.h \
        keys.c keys.h \
        have.h \
        ipv4.h \
@@ -107,6 +111,7 @@ tincd_SOURCES = \
        tincd.c \
        utils.c utils.h \
        xalloc.h \
+       xoshiro.c \
        version.c version.h \
        ed25519/ecdh.c \
        ed25519/ecdsa.c \
@@ -136,6 +141,7 @@ tinc_SOURCES = \
        ed25519/ecdh.c \
        ed25519/ecdsa.c \
        ed25519/ecdsagen.c \
+       xoshiro.c \
        $(ed25519_SOURCES) \
        $(chacha_poly1305_SOURCES)
 
@@ -144,6 +150,7 @@ sptps_test_SOURCES = \
        sptps.c sptps.h \
        sptps_test.c \
        utils.c utils.h \
+       xoshiro.c \
        ed25519/ecdh.c \
        ed25519/ecdsa.c \
        $(ed25519_SOURCES) \
@@ -212,54 +219,60 @@ endif
 
 if OPENSSL
 tincd_SOURCES += \
-       openssl/cipher.c \
+       openssl/cipher.c openssl/cipher.h \
        openssl/crypto.c \
        openssl/digest.c openssl/digest.h \
        openssl/prf.c \
-       openssl/rsa.c
+       openssl/rsa.c \
+       openssl/log.c openssl/log.h
 tinc_SOURCES += \
-       openssl/cipher.c \
+       openssl/cipher.c openssl/cipher.h \
        openssl/crypto.c \
        openssl/digest.c openssl/digest.h \
        openssl/prf.c \
        openssl/rsa.c \
-       openssl/rsagen.c
+       openssl/rsagen.c \
+       openssl/log.c openssl/log.h
 sptps_test_SOURCES += \
        openssl/crypto.c \
        openssl/digest.c openssl/digest.h \
-       openssl/prf.c
+       openssl/prf.c \
+       openssl/log.c openssl/log.h
 sptps_keypair_SOURCES += \
        openssl/crypto.c
 sptps_speed_SOURCES += \
        openssl/crypto.c \
        openssl/digest.c openssl/digest.h \
-       openssl/prf.c
+       openssl/prf.c \
+       openssl/log.c openssl/log.h
 else
 if GCRYPT
 tincd_SOURCES += \
-       gcrypt/cipher.c \
+       gcrypt/cipher.c gcrypt/cipher.h \
        gcrypt/crypto.c \
        gcrypt/digest.c gcrypt/digest.h \
+       gcrypt/pem.c gcrypt/pem.h \
        gcrypt/prf.c \
-       gcrypt/rsa.c
+       gcrypt/rsa.c gcrypt/rsa.h
 tinc_SOURCES += \
-       gcrypt/cipher.c \
+       gcrypt/cipher.c gcrypt/cipher.h \
        gcrypt/crypto.c \
        gcrypt/digest.c gcrypt/digest.h \
+       gcrypt/pem.c gcrypt/pem.h \
        gcrypt/prf.c \
-       gcrypt/rsa.c \
+       gcrypt/rsa.c gcrypt/rsa.h \
        gcrypt/rsagen.c
 sptps_test_SOURCES += \
-       gcrypt/cipher.c \
+       gcrypt/cipher.c gcrypt/cipher.h \
        gcrypt/crypto.c \
        gcrypt/digest.c gcrypt/digest.h \
        gcrypt/prf.c
 sptps_keypair_SOURCES += \
-       openssl/crypto.c
+       gcrypt/crypto.c
 sptps_speed_SOURCES += \
-       openssl/crypto.c \
-       openssl/digest.c openssl/digest.h \
-       openssl/prf.c
+       gcrypt/crypto.c \
+       gcrypt/digest.c gcrypt/digest.h \
+       gcrypt/prf.c
 else
 tincd_SOURCES += \
        nolegacy/crypto.c \
@@ -278,6 +291,13 @@ sptps_speed_SOURCES += \
 endif
 endif
 
+if WITH_LEGACY_PROTOCOL
+tinc_SOURCES        += digest.c
+tincd_SOURCES       += digest.c cipher.c
+sptps_test_SOURCES  += digest.c
+sptps_speed_SOURCES += digest.c
+endif
+
 if MINIUPNPC
 tincd_SOURCES += upnp.h upnp.c
 tincd_LDADD = $(MINIUPNPC_LIBS)