Use a smarter algorithm for choosing MTU discovery probe sizes.
[tinc] / src / Makefile.am
index 2738008..ea53ea2 100644 (file)
@@ -1,9 +1,36 @@
 ## Produce this file with automake to get Makefile.in
 
-sbin_PROGRAMS = tincd tinc sptps_test
+sbin_PROGRAMS = tincd tinc sptps_test sptps_keypair
+
+## Make sure version.c is always rebuilt
+.PHONY: version.c
+version.c:
+
+if LINUX
+sbin_PROGRAMS += sptps_speed
+endif
 
 DEFAULT_INCLUDES =
 
+ed25519_SOURCES = \
+       ed25519/add_scalar.c \
+       ed25519/ed25519.h \
+       ed25519/fe.c ed25519/fe.h \
+       ed25519/fixedint.h \
+       ed25519/ge.c ed25519/ge.h \
+       ed25519/key_exchange.c \
+       ed25519/keypair.c \
+       ed25519/precomp_data.h \
+       ed25519/sc.c ed25519/sc.h \
+       ed25519/sha512.c ed25519/sha512.h \
+       ed25519/sign.c \
+       ed25519/verify.c
+
+chacha_poly1305_SOURCES = \
+       chacha-poly1305/chacha.c chacha-poly1305/chacha.h \
+       chacha-poly1305/chacha-poly1305.c chacha-poly1305/chacha-poly1305.h \
+       chacha-poly1305/poly1305.c chacha-poly1305/poly1305.h
+
 tincd_SOURCES = \
        buffer.c buffer.h \
        cipher.h \
@@ -55,6 +82,7 @@ tincd_SOURCES = \
        route.c route.h \
        rsa.h \
        rsagen.h \
+       script.c script.h \
        splay_tree.c splay_tree.h \
        sptps.c sptps.h \
        subnet.c subnet.h \
@@ -62,7 +90,12 @@ tincd_SOURCES = \
        system.h \
        tincd.c \
        utils.c utils.h \
-       xalloc.h
+       xalloc.h \
+       version.c version.h \
+       ed25519/ecdh.c \
+       ed25519/ecdsa.c \
+       $(ed25519_SOURCES) \
+       $(chacha_poly1305_SOURCES)
 
 tinc_SOURCES = \
        dropin.c dropin.h \
@@ -73,17 +106,45 @@ tinc_SOURCES = \
        list.c list.h \
        names.c names.h \
        netutl.c netutl.h \
+       script.c script.h \
        sptps.c sptps.h \
        subnet_parse.c subnet.h \
        tincctl.c tincctl.h \
        top.c top.h \
-       utils.c utils.h
+       utils.c utils.h \
+       version.c version.h \
+       ed25519/ecdh.c \
+       ed25519/ecdsa.c \
+       ed25519/ecdsagen.c \
+       $(ed25519_SOURCES) \
+       $(chacha_poly1305_SOURCES)
 
 sptps_test_SOURCES = \
        logger.c logger.h \
        sptps.c sptps.h \
        sptps_test.c \
-       utils.c utils.h
+       utils.c utils.h \
+       ed25519/ecdh.c \
+       ed25519/ecdsa.c \
+       $(ed25519_SOURCES) \
+       $(chacha_poly1305_SOURCES)
+
+sptps_keypair_SOURCES = \
+       sptps_keypair.c \
+       utils.c utils.h \
+       ed25519/ecdsagen.c \
+       $(ed25519_SOURCES)
+
+sptps_speed_SOURCES = \
+       logger.c logger.h \
+       sptps.c sptps.h \
+       sptps_speed.c \
+       utils.c utils.h \
+       ed25519/ecdh.c \
+       ed25519/ecdsa.c \
+       ed25519/ecdsagen.c \
+       $(ed25519_SOURCES) \
+       $(chacha_poly1305_SOURCES)
 
 ## Conditionally compile device drivers
        
@@ -123,45 +184,37 @@ tincd_SOURCES += \
        openssl/cipher.c \
        openssl/crypto.c \
        openssl/digest.c openssl/digest.h \
-       openssl/ecdh.c \
-       openssl/ecdsa.c \
        openssl/prf.c \
        openssl/rsa.c
 tinc_SOURCES += \
        openssl/cipher.c \
        openssl/crypto.c \
        openssl/digest.c openssl/digest.h \
-       openssl/ecdh.c \
-       openssl/ecdsa.c \
-       openssl/ecdsagen.c \
        openssl/prf.c \
        openssl/rsa.c \
        openssl/rsagen.c
 sptps_test_SOURCES += \
-       openssl/cipher.c \
        openssl/crypto.c \
        openssl/digest.c openssl/digest.h \
-       openssl/ecdh.c \
-       openssl/ecdsa.c \
        openssl/prf.c
-endif
-
+sptps_keypair_SOURCES += \
+       openssl/crypto.c
+sptps_speed_SOURCES += \
+       openssl/crypto.c \
+       openssl/digest.c openssl/digest.h \
+       openssl/prf.c
+else
 if GCRYPT
 tincd_SOURCES += \
        gcrypt/cipher.c \
        gcrypt/crypto.c \
        gcrypt/digest.c gcrypt/digest.h \
-       gcrypt/ecdh.c \
-       gcrypt/ecdsa.c \
        gcrypt/prf.c \
        gcrypt/rsa.c
 tinc_SOURCES += \
        gcrypt/cipher.c \
        gcrypt/crypto.c \
        gcrypt/digest.c gcrypt/digest.h \
-       gcrypt/ecdh.c \
-       gcrypt/ecdsa.c \
-       gcrypt/ecdsagen.c \
        gcrypt/prf.c \
        gcrypt/rsa.c \
        gcrypt/rsagen.c
@@ -169,14 +222,35 @@ sptps_test_SOURCES += \
        gcrypt/cipher.c \
        gcrypt/crypto.c \
        gcrypt/digest.c gcrypt/digest.h \
-       gcrypt/ecdh.c \
-       gcrypt/ecdsa.c \
        gcrypt/prf.c
+sptps_keypair_SOURCES += \
+       openssl/crypto.c
+sptps_speed_SOURCES += \
+       openssl/crypto.c \
+       openssl/digest.c openssl/digest.h \
+       openssl/prf.c
+else
+tincd_SOURCES += \
+       nolegacy/crypto.c \
+       nolegacy/prf.c
+tinc_SOURCES += \
+       nolegacy/crypto.c \
+       nolegacy/prf.c
+sptps_test_SOURCES += \
+       nolegacy/crypto.c \
+       nolegacy/prf.c
+sptps_keypair_SOURCES += \
+       nolegacy/crypto.c
+sptps_speed_SOURCES += \
+       nolegacy/crypto.c \
+       nolegacy/prf.c
+endif
 endif
 
 tinc_LDADD = $(READLINE_LIBS) $(CURSES_LIBS)
+sptps_speed_LDADD = -lrt
 
-LIBS = @LIBS@ @LIBGCRYPT_LIBS@
+LIBS = @LIBS@ -lm
 
 if TUNEMU
 LIBS += -lpcap