Use a smarter algorithm for choosing MTU discovery probe sizes.
[tinc] / src / Makefile.am
index 5c8a841..ea53ea2 100644 (file)
@@ -203,7 +203,8 @@ sptps_speed_SOURCES += \
        openssl/crypto.c \
        openssl/digest.c openssl/digest.h \
        openssl/prf.c
-elif GCRYPT
+else
+if GCRYPT
 tincd_SOURCES += \
        gcrypt/cipher.c \
        gcrypt/crypto.c \
@@ -244,11 +245,12 @@ sptps_speed_SOURCES += \
        nolegacy/crypto.c \
        nolegacy/prf.c
 endif
+endif
 
 tinc_LDADD = $(READLINE_LIBS) $(CURSES_LIBS)
 sptps_speed_LDADD = -lrt
 
-LIBS = @LIBS@
+LIBS = @LIBS@ -lm
 
 if TUNEMU
 LIBS += -lpcap