Add ability to use proxies to connect to hostnames when there is no nameserver.
[tinc] / src / Makefile.am
index 9a18109..ebd52ab 100644 (file)
@@ -1,25 +1,87 @@
 ## Produce this file with automake to get Makefile.in
-# $Id: Makefile.am,v 1.4.4.15 2001/10/28 08:41:19 guus Exp $
 
 sbin_PROGRAMS = tincd
 
-tincd_SOURCES = conf.c connection.c device.c meta.c net.c netutl.c node.c process.c    \
-       protocol.c route.c subnet.c tincd.c edge.c
+tincd_SOURCES = \
+       have.h \
+       system.h \
+       avl_tree.c avl_tree.h \
+       conf.c conf.h \
+       connection.c connection.h \
+       device.h \
+       dropin.c dropin.h \
+       dummy_device.c \
+       edge.c edge.h \
+       ethernet.h \
+       event.c event.h \
+       fake-gai-errnos.h \
+       fake-getaddrinfo.c fake-getaddrinfo.h \
+       fake-getnameinfo.c fake-getnameinfo.h \
+       getopt.c getopt.h \
+       getopt1.c \
+       graph.c graph.h \
+       ipv4.h \
+       ipv6.h \
+       list.c list.h \
+       logger.c logger.h \
+       meta.c meta.h \
+       multicast_device.c \
+       net.c net.h \
+       net_packet.c \
+       net_setup.c \
+       net_socket.c \
+       netutl.c netutl.h \
+       node.c node.h \
+       pidfile.c pidfile.h \
+       process.c process.h \
+       protocol.c protocol.h \
+       protocol_auth.c \
+       protocol_edge.c \
+       protocol_misc.c \
+       protocol_key.c \
+       protocol_subnet.c \
+       proxy.c proxy.h \
+       raw_socket_device.c \
+       route.c route.h \
+       subnet.c subnet.h \
+       tincd.c \
+       utils.c utils.h \
+       xalloc.h \
+       xmalloc.c
 
-INCLUDES = @INCLUDES@ -I$(top_builddir) -I$(top_srcdir)/lib -I$(top_srcdir)/intl
+if LINUX
+tincd_SOURCES += linux/device.c
+endif
 
-noinst_HEADERS = conf.h connection.h device.h meta.h net.h netutl.h node.h process.h   \
-       protocol.h route.h subnet.h edge.h
+if BSD
+tincd_SOURCES += bsd/device.c
+if TUNEMU
+tincd_SOURCES += bsd/tunemu.c bsd/tunemu.h
+endif
+endif
 
-LIBS = @LIBS@ @INTLLIBS@
+if SOLARIS
+tincd_SOURCES += solaris/device.c
+endif
 
-tincd_LDADD = \
-       $(top_builddir)/lib/libvpn.a
+if MINGW
+tincd_SOURCES += mingw/device.c mingw/common.h
+endif
 
-localedir = $(datadir)/locale
+if CYGWIN
+tincd_SOURCES += cygwin/device.c
+endif
 
-CFLAGS = @CFLAGS@ -DPKGLIBDIR=$(pkglibdir) -DCONFDIR=\"$(sysconfdir)\" \
-       -DLOCALEDIR=\"$(localedir)\" -DLOCALSTATEDIR=\"$(localstatedir)\"
+if UML
+tincd_SOURCES += uml_device.c
+endif
 
-lint: $(tincd_SOURCES)
-       lclint -nullassign -nullret +trytorecover +posixlib -skipansiheaders -skipposixheaders +gnuextensions -I/usr/include -I/usr/lib/gcc-lib/i386-linux/2.95.2/include -I. -I/home/zarq/p/tinc/cvs/cabal/src -I.. -I.. -I/home/zarq/p/tinc/cvs/cabal/lib -I/home/zarq/p/tinc/cvs/cabal/intl -D_POSIX_SOURCE -D__ELF__ -Dunix -D__i386__ -Dlinux -DHAVE_CONFIG_H -DPKGLIBDIR=/usr/local/lib/tinc -DCONFDIR=\"/usr/local/etc\" -DLOCALEDIR=\"/usr/local/share/locale\" $^
+if VDE
+tincd_SOURCES += vde_device.c
+endif
+
+if TUNEMU
+LIBS += -lpcap
+endif
+
+AM_CPPFLAGS = -DCONFDIR=\"$(sysconfdir)\" -DLOCALSTATEDIR=\"$(localstatedir)\"