Don't assume sa.sa_family is a short int.
[tinc] / src / Makefile.am
index 7de9ecb..ef7c08d 100644 (file)
@@ -2,11 +2,14 @@
 
 sbin_PROGRAMS = tincd tinc sptps_test sptps_keypair
 
-## Make sure version.c is always rebuilt with the latest git information
-.PHONY: ${srcdir}/version.c version_git.h
-version_git.h:
-       echo >$@
-       -(cd $(srcdir) && git describe) && echo '#define GIT_DESCRIPTION "'`(cd $(srcdir) && git describe) | sed 's/release-//'`'"' >$@
+CLEANFILES = version_git.h
+
+.PHONY: version-stamp
+version-stamp:
+
+version_git.h: version-stamp
+       $(AM_V_GEN)echo >$@
+       @-(cd $(srcdir) && git describe 2>/dev/null >/dev/null) && echo '#define GIT_DESCRIPTION "'`(cd $(srcdir) && git describe) | sed 's/release-//'`'"' >$@ ||:
 ${srcdir}/version.c: version_git.h
 
 if LINUX
@@ -50,9 +53,6 @@ tincd_SOURCES = \
        edge.c edge.h \
        ethernet.h \
        event.c event.h \
-       fake-gai-errnos.h \
-       fake-getaddrinfo.c fake-getaddrinfo.h \
-       fake-getnameinfo.c fake-getnameinfo.h \
        graph.c graph.h \
        hash.c hash.h \
        have.h \
@@ -98,8 +98,6 @@ tincd_SOURCES = \
 
 tinc_SOURCES = \
        dropin.c dropin.h \
-       getopt.c getopt.h \
-       getopt1.c \
        fsck.c fsck.h \
        info.c info.h \
        invitation.c invitation.h \
@@ -154,7 +152,7 @@ tincd_SOURCES += \
        getopt1.c
 tinc_SOURCES += \
        getopt.c getopt.h \
-       getopt1.cendif
+       getopt1.c
 sptps_test_SOURCES += \
        getopt.c getopt.h \
        getopt1.c