Remove redundant @CFLAGS@ from AM_CFLAGS.
[tinc] / src / Makefile.am
index d769071..ff011f8 100644 (file)
@@ -1,28 +1,36 @@
 ## Produce this file with automake to get Makefile.in
-# $Id: Makefile.am,v 1.4.4.20 2002/02/18 16:25:16 guus Exp $
 
 sbin_PROGRAMS = tincd
 
-EXTRA_DIST = linux/device.c freebsd/device.c openbsd/device.c solaris/device.c
+EXTRA_DIST = linux/device.c bsd/device.c solaris/device.c cygwin/device.c mingw/device.c mingw/common.h raw_socket/device.c uml_socket/device.c
 
-tincd_SOURCES = conf.c connection.c device.c edge.c event.c graph.c meta.c net.c net_packet.c net_setup.c      \
+tincd_SOURCES = conf.c connection.c edge.c event.c graph.c logger.c meta.c net.c net_packet.c net_setup.c      \
        net_socket.c netutl.c node.c process.c protocol.c protocol_auth.c protocol_edge.c protocol_misc.c       \
        protocol_key.c protocol_subnet.c route.c subnet.c tincd.c
 
-INCLUDES = @INCLUDES@ -I$(top_builddir) -I$(top_srcdir)/lib -I$(top_srcdir)/intl
+if TUNEMU
+tincd_SOURCES += bsd/tunemu.c
+endif
 
-noinst_HEADERS = conf.h connection.h device.h edge.h event.h graph.h meta.h net.h netutl.h node.h process.h    \
-       protocol.h route.h subnet.h
+nodist_tincd_SOURCES = device.c
 
-LIBS = @LIBS@ @INTLLIBS@
+DEFAULT_INCLUDES =
+
+INCLUDES = @INCLUDES@ -I$(top_builddir) -I$(top_srcdir)/lib
+
+noinst_HEADERS = conf.h connection.h device.h edge.h event.h graph.h logger.h meta.h net.h netutl.h node.h process.h   \
+       protocol.h route.h subnet.h bsd/tunemu.h
+
+LIBS = @LIBS@
+
+if TUNEMU
+LIBS += -lpcap
+endif
 
 tincd_LDADD = \
        $(top_builddir)/lib/libvpn.a
 
-localedir = $(datadir)/locale
-
-CFLAGS = @CFLAGS@ -DPKGLIBDIR=$(pkglibdir) -DCONFDIR=\"$(sysconfdir)\" \
-       -DLOCALEDIR=\"$(localedir)\" -DLOCALSTATEDIR=\"$(localstatedir)\"
+AM_CFLAGS = -DCONFDIR=\"$(sysconfdir)\" -DLOCALSTATEDIR=\"$(localstatedir)\"
 
-lint: $(tincd_SOURCES)
-       lclint -nullassign -nullret +trytorecover +posixlib -skipansiheaders -skipposixheaders +gnuextensions -I/usr/include -I/usr/lib/gcc-lib/i386-linux/2.95.2/include -I. -I/home/zarq/p/tinc/cvs/cabal/src -I.. -I.. -I/home/zarq/p/tinc/cvs/cabal/lib -I/home/zarq/p/tinc/cvs/cabal/intl -D_POSIX_SOURCE -D__ELF__ -Dunix -D__i386__ -Dlinux -DHAVE_CONFIG_H -DPKGLIBDIR=/usr/local/lib/tinc -DCONFDIR=\"/usr/local/etc\" -DLOCALEDIR=\"/usr/local/share/locale\" $^
+dist-hook:
+       rm -f `find . -type l`