Split event.c into per-API files
[tinc] / src / bsd / meson.build
index 91bc550..cc29479 100644 (file)
@@ -6,11 +6,6 @@ check_headers += [
   'net/tun/if_tun.h',
 ]
 
-# macOS apparently doesn't support kqueue with TAP devices
-if os_name != 'darwin'
-  check_headers += 'sys/event.h'
-endif
-
 check_functions += [
   'devname',
   'fdevname',
@@ -18,6 +13,10 @@ check_functions += [
 
 src_tincd += files('device.c')
 
+if os_name != 'darwin'
+  src_tincd += files('event.c')
+endif
+
 if os_name in ['openbsd', 'darwin']
   subdir(os_name)
 endif