meson: use Python script for version detection
[tinc] / src / include / meson.build
index 0550996..f8e6f0d 100644 (file)
@@ -1,7 +1,7 @@
 configure_file(output: 'config.h', configuration: cdata)
 
 src_lib_common += vcs_tag(
-  command: ['git', 'describe', '--always', '--tags', '--match=release-*'],
+  command: [python_path, src_root / 'version.py'],
   fallback: 'unknown',
   input: '../version_git.h.in',
   output: 'version_git.h',