Test running ping through two tinc daemons.
[tinc] / test / Makefile.am
index 7a09576..dac577d 100644 (file)
@@ -4,12 +4,18 @@ TESTS = \
        executables.test \
        import-export.test \
        invite-join.test \
+       ping.test \
        sptps-basic.test \
        variables.test
 
 EXTRA_DIST = testlib.sh
 
+check_PROGRAMS = pong
+
+pong_SOURCES = pong.c
+
 clean-local:
        -for pid in *.test.?/pid; do ../src/tinc --pidfile="$$pid" stop; done
        -killall ../src/sptps_test
+       -killall pong
        -rm -rf *.test.?