Don't assume sa.sa_family is a short int.
[tinc] / test / Makefile.am
index 7a09576..5457b2f 100644 (file)
@@ -4,12 +4,21 @@ TESTS = \
        executables.test \
        import-export.test \
        invite-join.test \
+       ns-ping.test \
+       ping.test \
        sptps-basic.test \
        variables.test
 
+dist_check_SCRIPTS = $(TESTS)
+
 EXTRA_DIST = testlib.sh
 
+check_PROGRAMS = pong
+
+pong_SOURCES = pong.c
+
 clean-local:
        -for pid in *.test.?/pid; do ../src/tinc --pidfile="$$pid" stop; done
        -killall ../src/sptps_test
+       -killall pong
        -rm -rf *.test.?