Prevent oracle attacks in the legacy protocol (CVE-2018-16737, CVE-2018-16738)
[tinc] / test / Makefile.am
index 0bd66c7..9c2f001 100644 (file)
@@ -7,7 +7,8 @@ TESTS = \
        invite-offline.test \
        invite-tinc-up.test \
        ns-ping.test \
-       ping.test \
+       scripts.test \
+       security.test \
        sptps-basic.test \
        variables.test
 
@@ -15,12 +16,14 @@ dist_check_SCRIPTS = $(TESTS)
 
 EXTRA_DIST = testlib.sh
 
-check_PROGRAMS = pong
+AM_CFLAGS = -iquote.
 
-pong_SOURCES = pong.c
+check_PROGRAMS = \
+       splice
+
+splice_SOURCES = splice.c
 
 clean-local:
        -for pid in *.test.?/pid; do ../src/tinc --pidfile="$$pid" stop; done
        -killall ../src/sptps_test
-       -killall pong
        -rm -rf *.test.?