Prevent oracle attacks in the legacy protocol (CVE-2018-16737, CVE-2018-16738)
[tinc] / test / Makefile.am
index 4cb5f3f..9c2f001 100644 (file)
@@ -1,10 +1,29 @@
 TESTS = \
        basic.test \
+       commandline.test \
        executables.test \
        import-export.test \
-       sptps-basic.test
+       invite-join.test \
+       invite-offline.test \
+       invite-tinc-up.test \
+       ns-ping.test \
+       scripts.test \
+       security.test \
+       sptps-basic.test \
+       variables.test
+
+dist_check_SCRIPTS = $(TESTS)
 
 EXTRA_DIST = testlib.sh
 
+AM_CFLAGS = -iquote.
+
+check_PROGRAMS = \
+       splice
+
+splice_SOURCES = splice.c
+
 clean-local:
+       -for pid in *.test.?/pid; do ../src/tinc --pidfile="$$pid" stop; done
+       -killall ../src/sptps_test
        -rm -rf *.test.?