Add a test for tinc-up creation from invitations.
[tinc] / test / Makefile.am
index 15db24f..df8e2c3 100644 (file)
@@ -1,12 +1,25 @@
 TESTS = \
        basic.test \
+       commandline.test \
        executables.test \
        import-export.test \
-       sptps-basic.test
+       invite-join.test \
+       invite-tinc-up.test \
+       ns-ping.test \
+       ping.test \
+       sptps-basic.test \
+       variables.test
+
+dist_check_SCRIPTS = $(TESTS)
 
 EXTRA_DIST = testlib.sh
 
+check_PROGRAMS = pong
+
+pong_SOURCES = pong.c
+
 clean-local:
        -for pid in *.test.?/pid; do ../src/tinc --pidfile="$$pid" stop; done
        -killall ../src/sptps_test
+       -killall pong
        -rm -rf *.test.?