Add a test for tinc-up creation from invitations.
[tinc] / test / Makefile.am
index 7a09576..df8e2c3 100644 (file)
@@ -4,12 +4,22 @@ TESTS = \
        executables.test \
        import-export.test \
        invite-join.test \
+       invite-tinc-up.test \
+       ns-ping.test \
+       ping.test \
        sptps-basic.test \
        variables.test
 
+dist_check_SCRIPTS = $(TESTS)
+
 EXTRA_DIST = testlib.sh
 
+check_PROGRAMS = pong
+
+pong_SOURCES = pong.c
+
 clean-local:
        -for pid in *.test.?/pid; do ../src/tinc --pidfile="$$pid" stop; done
        -killall ../src/sptps_test
+       -killall pong
        -rm -rf *.test.?