GitHub CI: change build system to meson
[tinc] / .ci / package / rpm / tinc.spec
1 Name:           tinc
2 Version:        __VERSION__
3 Release:        3%{?dist}
4 Summary:        A virtual private network daemon
5
6 License:        GPLv2+
7 URL:            https://www.tinc-vpn.org/
8
9 BuildRequires: gcc
10 BuildRequires: meson
11 BuildRequires: systemd
12 BuildRequires: openssl-devel
13 BuildRequires: lzo-devel
14 BuildRequires: zlib-devel
15 BuildRequires: lz4-devel
16 BuildRequires: ncurses-devel
17 BuildRequires: readline-devel
18
19 Requires(post):   systemd
20 Requires(preun):  systemd
21 Requires(postun): systemd
22
23 %description
24 tinc is a Virtual Private Network (VPN) daemon that uses tunnelling
25 and encryption to create a secure private network between hosts on
26 the Internet. Because the tunnel appears to the IP level network
27 code as a normal network device, there is no need to adapt any
28 existing software. This tunnelling allows VPN sites to share
29 information with each other over the Internet without exposing any
30 information to others.
31
32 %define debug_package %{nil}
33 %define __meson_auto_features auto
34
35 %prep
36
37 %build
38 %meson
39 %meson_build
40
41 %install
42 %meson_install
43
44 %post
45 %systemd_post %{name}@.service
46
47 %preun
48 %systemd_preun %{name}@.service
49
50 %postun
51 %systemd_postun_with_restart %{name}@.service
52
53 %files
54 %doc AUTHORS COPYING.README NEWS README.md THANKS doc/sample*
55 %license COPYING
56 %{_mandir}/man*/%{name}*.*
57 %{_infodir}/%{name}.info.*
58 %{_sbindir}/%{name}
59 %{_sbindir}/%{name}d
60 %{_unitdir}/%{name}*.service
61 %{_datadir}/bash-completion/completions/%{name}