707587d8561b3551995afd0e9e497647090c6e46
[tinc] / .ci / package / rpm / tinc.spec
1 Name:           tinc
2 Version:        __VERSION__
3 Release:        3%{?dist}
4 Summary:        A virtual private network daemon
5
6 License:        GPLv2+
7 URL:            https://www.tinc-vpn.org/
8
9 BuildRequires: systemd
10
11 Requires(post):   systemd
12 Requires(preun):  systemd
13 Requires(postun): systemd
14
15 %description
16 tinc is a Virtual Private Network (VPN) daemon that uses tunnelling
17 and encryption to create a secure private network between hosts on
18 the Internet. Because the tunnel appears to the IP level network
19 code as a normal network device, there is no need to adapt any
20 existing software. This tunnelling allows VPN sites to share
21 information with each other over the Internet without exposing any
22 information to others.
23
24 %define debug_package %{nil}
25
26 %prep
27
28 %build
29 %configure --with-systemd=%{_unitdir} __CONFIGURE_ARGS__
30 %make_build
31
32 %install
33 %make_install
34 rm -f %{buildroot}%{_infodir}/dir
35
36 %post
37 %systemd_post %{name}@.service
38
39 %preun
40 %systemd_preun %{name}@.service
41
42 %postun
43 %systemd_postun_with_restart %{name}@.service
44
45 %files
46 %doc AUTHORS COPYING.README NEWS README THANKS doc/sample* doc/*.tex
47 %license COPYING
48 %{_mandir}/man*/%{name}*.*
49 %{_infodir}/%{name}.info.*
50 %{_sbindir}/%{name}
51 %{_sbindir}/%{name}d
52 %{_unitdir}/%{name}*.service
53 %{_datadir}/bash-completion/completions/%{name}